Private Browsing onboarding on Android confusingly deadends in support for desktop

RESOLVED DUPLICATE of bug 1222181

Status

()

Firefox for Android
First Run
RESOLVED DUPLICATE of bug 1222181
3 years ago
3 years ago

People

(Reporter: jib, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

Just downloaded 42 update in play store, clicked big "Try Private Browsing" button and was taken to descriptions and screenshots of how it works on desktop. Confusing.

Comment 1

3 years ago
(In reply to Jan-Ivar Bruaroey [:jib] from comment #0)
> Just downloaded 42 update in play store, clicked big "Try Private Browsing"
> button and was taken to descriptions and screenshots of how it works on
> desktop. Confusing.

I'm afraid I don't know what button you're talking about. Where did you see this button?
Flags: needinfo?(jib)
There is a snippet ad in about:home for private browsing. It looks to go to the desktop PB site.
Created attachment 8683749 [details]
Screenshot of in browser snippet
Created attachment 8683750 [details]
Screenshot of mozilla.org
Created attachment 8683751 [details]
Screenshot of sumo
Attributing to the confusion: in the desktop layout, "for Desktop", "for Android" and "Firefox OS" are clearly in-content "tabs", whereas on Android (see attachment 8683750 [details]) this is not obvious at all. I went straight for the big button and ended up in sumo (attachment 8683750 [details]).

Comment 8

3 years ago
Jean, is this a problem with our snippet campaign? Can we update the URL for these snippets?
Flags: needinfo?(jcollings)
Hi all.

I'd like to confirm what's being asked here.

1. The fact that the snippet links to firefox/private-browsing is not the issue.
2. The problem is that when an Android user clicks on the CTA, he or she is taken to a desktop specific SUMO article.

Change requested:

When an Android user clicks the CTA on the Private Browsing product page[0], he or she should be sent to the Android specific PB SUMO article[1].

Please confirm NI, and we'll open a work stream to get the link on the PB product page updated.

[0]https://www.mozilla.org/firefox/private-browsing/
[1]https://support.mozilla.org/kb/private-browsing-firefox-android
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(kbrosnan)
Flags: needinfo?(jib)
Note: as an immediate stop-gap until the product page is updated, we will update the snippet to link directly to the Android SUMO article.
Spoke with :habber, we're going to run with the updates to the product page in comment 9 with bug 1222181.

We're putting the temporary fix in comment 10 effective immediately.
Flags: needinfo?(margaret.leibovic)
Flags: needinfo?(kbrosnan)
Flags: needinfo?(jib)
There is no Firefox for Android code change needed so this seems to be a dupe of the mozilla.org bug.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222181
You need to log in before you can comment on or make changes to this bug.