about:addons section entries need link to AMO

RESOLVED DUPLICATE of bug 1215863

Status

()

RESOLVED DUPLICATE of bug 1215863
3 years ago
3 years ago

People

(Reporter: relay12, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:25.0) Gecko/20100101 Firefox/25.0
Build ID: 20131112160018

Steps to reproduce:

Goto about:addons and select appearance section 


Actual results:

The individual entries only list name and the author but no hyper links to addons.mozilla.org (AMO).


Expected results:

Hyperlink to author and to theme's page on addons.mozilla.org (AMO) and link to reviews section on AMO theme page so it is consistent with "extensions" section.

On extensions section I have to use the reviews links to navigate to extensions AMO page as there is not direct link to AMO page. Example: https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/reviews/?src=api.  It would also make sense that "themes" and "extensions" have direct links to AMO pages.

Justification:
Trying to find AMO page is difficult for example, theme name in about:addons is "vivid_sidney_13_08". I tried search AMO for "vivid sidney 13 08" or "vivid_sidney_13_08" - It DOES NOT find theme on first attempt. This link is https://addons.mozilla.org/En-us/firefox/addon/vivid_sidney_13_08/. (Note once you view that page the same search find the result)

Here are the usage cases for having a link: you want to share a theme with someone, add it to your personal collection, give person hyperlink or you want to find it to rate it. All are too difficult to do with out a link. It is also inconsistent with "extensions" section.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows
Hardware: Unspecified → x86

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Add-ons Manager
OS: Windows → All
Product: Firefox → Toolkit
Hardware: x86 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1215863
You need to log in before you can comment on or make changes to this bug.