In Firefox 42, there is an issue with cookie handling.

RESOLVED DUPLICATE of bug 1210379

Status

()

Core
Permission Manager
RESOLVED DUPLICATE of bug 1210379
3 years ago
3 years ago

People

(Reporter: Ron, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8683550 [details]
Cookies Rejected and Accepted at the Same Time - Marked.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

Created new Firefox profile and also tested a new Firefox 42 installation on a different machine.


Actual results:

In Firefox 42, there is an issue with cookie handling.

For instance, when “Accept cookies from sites” is unchecked (disallowed) but you enter a domain such as “google.com” (to allow only google.com), Firefox will still not accept google.com’s cookie. (Here, you're telling Firefox "do not accept cookies but accept the ones listed from these domains".)

Notes:
- This also occurs when there are no add-ons installed.
- This bug/error can be seen through related add-ons such as Cookie Monster (shown in the screenshot). The add-on menu shows cookies from the same website are both accepted and rejected - which is not possible.
- The cookie’s option can be found:   Options  >  Privacy  >  - History -  >  “Accept cookies from site”.


Expected results:

Cookies should be accepted by Firefox when the domain is listed in “Accept cookies from site” even though “Accept cookies from sites” is unchecked.

Comment 1

3 years ago
(In reply to Ron from comment #0)
> For instance, when “Accept cookies from sites” is unchecked (disallowed) but
> you enter a domain such as “google.com” (to allow only google.com), Firefox
> will still not accept google.com’s cookie.

Cookie exceptions must now specify the procotol as well. By default, simply typing in google.com will create the exception http://google.com which won't help because most pages on that domain are over HTTPS. Add https://google.com as an exception.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → Permission Manager
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1210379
You need to log in before you can comment on or make changes to this bug.