Tab muting doesn't work with html5 video on periscope.tv

RESOLVED DUPLICATE of bug 1228564

Status

()

RESOLVED DUPLICATE of bug 1228564
3 years ago
3 years ago

People

(Reporter: kernp25, Assigned: baku)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151104030437

Steps to reproduce:

Go to https://www.periscope.tv/
Start the video (click the play button)




Actual results:

The mute icon will not show (sound is present)
Right-clicking on the tab and choosing "Mute Tab" item also does not mute the tab (tested with newest nightly 45.0a1)


Expected results:

periscope.tv should have muted.
The mute icon should have displayed.
(Reporter)

Updated

3 years ago
Version: Firefox 42 → Firefox 45
(Reporter)

Updated

3 years ago
Moving to Core audio/video (unless we have a reason to suspect this plugin muting problem is a site bug?).
Component: Desktop → Audio/Video
Product: Tech Evangelism → Core
Version: Firefox 45 → 45 Branch
FWIW, using the latest Nightly (from Nov 5th), muting the tab worked for me: it muted the video. I did not see a mute icon though. I believe this bug should be against the controls of the media element. I'm moving this to Firefox::General since I'm not sure exactly which component this should go to and I know Firefox::General gets triaged regularly.
Component: Audio/Video → General
Product: Core → Firefox
(Reporter)

Comment 3

3 years ago
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #2)
> FWIW, using the latest Nightly (from Nov 5th), muting the tab worked for me:
> it muted the video.
No, It does NOT work for me!
The tab (page) is not muted (i can clearly hear the sound)
I have tested this with Nightly 45.0a1 (2015-11-05) in a new profile.

> I did not see a mute icon though. I believe this bug
> should be against the controls of the media element.

In Google Chrome (Version 46.0.2490.80 m (64-bit)) it works just fine (the sound icon is displayed and choosing "Mute tab" in tab context menu also mutes the tab). Why it is NOT working in Firefox?
(In reply to kernp25 from comment #3)
> (In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #2)
> > FWIW, using the latest Nightly (from Nov 5th), muting the tab worked for me:
> > it muted the video.

Same for me, Nightly on OSX I can mute the tab, but only via right-click. There's no visible icon until I mute it.

> No, It does NOT work for me!
> The tab (page) is not muted (i can clearly hear the sound)
> I have tested this with Nightly 45.0a1 (2015-11-05) in a new profile.
...
> mutes the tab). Why it is NOT working in Firefox?

It's not working because it's a bug. 

Please be patient (and polite) and hopefully someone can fix it.
(In reply to Mike Taylor [:miketaylr] from comment #4)
> Same for me, Nightly on OSX I can mute the tab, but only via right-click.
> There's no visible icon until I mute it.
Same for me in latest nightly 45.0a1 (2015-12-07) Win 7 x64.
Blocks: 1188860
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browser
Ever confirmed: true

Comment 6

3 years ago
Andrea, can you please take a look, please?
Flags: needinfo?(amarchesini)
(Assignee)

Updated

3 years ago
Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
(Assignee)

Comment 7

3 years ago
Created attachment 8696802 [details] [diff] [review]
ac1.patch

This is actually what Alwu wanted to implement.
Attachment #8696802 - Flags: review?(ehsan)
Attachment #8696802 - Flags: feedback?
(Assignee)

Updated

3 years ago
Attachment #8696802 - Flags: feedback?

Updated

3 years ago
Attachment #8696802 - Flags: review?(ehsan) → review+

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1228564
You need to log in before you can comment on or make changes to this bug.