Repeated painting in "Live WebVTT Viewer" causes too much CPU usage

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: zcorpan, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

(Reporter)

Description

3 years ago
Using Firefox Nightly 44.0a1 (2015-10-20)

1. Go to https://rawgit.com/zcorpan/live-webvtt-viewer/53d360d8225fc980778ebdd03d5e6f6a0cae5ef9/index.html
(snapshot version of https://zcorpan.github.io/live-webvtt-viewer/ at the time of reporting this bug)
2. Type an "x" or whatever at the end of the "VTT" textarea.
3. Click "Save to address bar".

Actual result
Something causes Firefox to use more CPU than without doing step 3 above.

In devtools, I tried adding breakpoints in the script, and AFAICT the script is just run once when clicking the button, as intended; it's not looping "onhashchange" or anything.

In the performance profiler, things are a-OK before clicking the button, but after clicking the button there is a lot of painting going on.

(I don't know whether this applies on all platforms.)
Component: Audio/Video → Audio/Video: Playback
Priority: -- → P2
Mass change P2 -> P3
Priority: P2 → P3
(Reporter)

Comment 2

2 years ago
Can't reproduce anymore in 49.0a1 (2016-05-25)
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.