Some sites that use Flash Player don't work correctly on the 64-bit version of Firefox

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: bugreporter, Unassigned)

Tracking

({64bit, flashplayer})

42 Branch
x86_64
Windows 7
64bit, flashplayer
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

I installed a fresh copy of Windows and I'm using the latest stable 64bit version of Firefox (42.0) and the latest stable version of Adobe Flash Player (19.0.0.226).
I noticed Flash Player issues on some sites. 
I even disabled my Firefox extensions but it didn't help. 
Notice that these problems don't occur on the 32-bit version of Firefox (latest stable version installed on my second PC).


Actual results:

On the site haxball.com:
- You see a grey background (http://s12.postimg.org/sapdlin4d/badhaxball.jpg). I also disabled hardware acceleration but it didn't help
- You can't open the Developer Toolbar by pressing Shift + F2 (I was trying to take a screenshot, it didn't work, so I used Windows Snipping Tool)

On the site stream2watch.co:
- You can't switch to HD and the volume slider is set to minimum (http://s16.postimg.org/tlllvqlmd/stream.jpg)

On some adult sites: 
- You can't watch the videos and live cams because of the white background

On the site miniclip.com:
- If you play the game called Soccer Stars, sometimes you have to reload the page because the game hangs up.


Expected results:

On the site haxball.com:
- You should see a box to enter your nick (http://s11.postimg.org/aumfo23ib/goodhaxball.png)

On the site stream2watch.co:
- You should watch the stream with no audio, but you actually can hear the audio
(Reporter)

Updated

2 years ago
Keywords: 64bit, flashplayer
OS: Unspecified → Windows 7
(Reporter)

Updated

2 years ago
Severity: normal → critical
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
(Reporter)

Updated

2 years ago
Severity: critical → normal
(Reporter)

Comment 1

2 years ago
I wrote I installed a fresh copy of windows, but I was also using CCleaner and some registry cleaners, so that's why these described here issues are my fault. Sorry!
You need to log in before you can comment on or make changes to this bug.