On-screen keyboard is not displayed on Microsoft Surface Pro 2

RESOLVED DUPLICATE of bug 1221947

Status

()

RESOLVED DUPLICATE of bug 1221947
3 years ago
3 years ago

People

(Reporter: cornel_ionce, Unassigned)

Tracking

Trunk
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reproduced with: Firefox 45.0a1 (2015-11-04), Firefox 44.0a2 (2015-11-04) and Firefox 43 Beta 1 build 2.
Reproduced on a MS Pro 2 device running Windows 10 64bit.

STR
1. Launch Firefox using a clean profile.
2. Go to about:config and make sure that the "ui.osk.enabled" pref is set to true.
3. Tap a text field / navigate to a website with a log in form.

Expected result:
The on-screen keyboard is automatically displayed.

Actual results:
The OSK does not appear when focusing/tapping a textbox.


Notes:
* The OSK does show up within a password field when table mode is enabled and e10s is disabled.
* The "ui.osk.debug.keyboardDisplayReason" shows IKPOS: Keyboard presence confirmed.
* It reproduces in both normal and tablet modes.
* Not sure if this also reproduces on other devices and if it's only Win10 specific.
Can you (or Jim) post a screenshot of using this tool:

http://www.nirsoft.net/utils/usb_devices_view.html

on the surface pro 2 when the keyboard is disconnected? Can you show the difference between that state and the one where the keyboard *is* connected?
Flags: needinfo?(cornel.ionce)
Sure, I'm adding a few screenshots with the mentioned tool.

Before adding a keyboard: http://i.imgur.com/Ceh2cKh.png
Keyboard plugged in: http://i.imgur.com/YOO4tX2.png
Keyboard unplugged: http://i.imgur.com/qrwYLjS.png

Please let me know if I can provide further information.
Flags: needinfo?(cornel.ionce)

Comment 3

3 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Can you (or Jim) post a screenshot of using this tool:
> 
> http://www.nirsoft.net/utils/usb_devices_view.html
> 
> on the surface pro 2 when the keyboard is disconnected? Can you show the
> difference between that state and the one where the keyboard *is* connected?

hrm, this locked up at launch on my surface pro.

Comment 4

3 years ago
Just checking via device manager though, when I connect/disconnect the bluetooth keyboard, device manager updates. So picking up these changes is possible, we just have to find the right way to do it.
Tracking as this may be a regression from recent work on touch screen keyboard displays.
tracking-firefox43: --- → +
tracking-firefox44: --- → +
tracking-firefox45: --- → +
The interesting fact here is that the bug stopped reproducing when the fix for bug 1221947 landed.

Could that fix also cover this scenario? Should we mark this fixed by bug 1221947?
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Cornel Ionce [QA] from comment #6)
> The interesting fact here is that the bug stopped reproducing when the fix
> for bug 1221947 landed.
> 
> Could that fix also cover this scenario? Should we mark this fixed by bug
> 1221947?

Yes, I more or less expected this to be the case. Thanks for confirming!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 1221947
status-firefox43: affected → ---
status-firefox44: affected → ---
status-firefox45: affected → ---
tracking-firefox43: + → ---
tracking-firefox44: + → ---
tracking-firefox45: + → ---
You need to log in before you can comment on or make changes to this bug.