task inspector: failed to run linux test due to missing v4l2loopback device

RESOLVED FIXED

Status

Taskcluster
Tools
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: jmaher, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
trying to run the task listed here:
https://tools.taskcluster.net/task-inspector/#CgkRCrP6SnO6g7aXyF7rvw/

I get an error due to:
ERROR Couldn't find a v4l2loopback video device

I am working to figure this out locally, but having some general docs on how to make this work will be a pre-requisite for developers to actually use docker images to reproduce/debug problems.
(Reporter)

Comment 1

2 years ago
I did this (on the host):
apt-get install v4l2loopback-dkms
modprobe v4l2loopback devices=4

then in the command to run docker, I added "--device=/dev/video1:/dev/video1", so my command looks like:
    docker run -ti \
      --name "${NAME}" \
      --device=/dev/video0:/dev/video0 \
      -e MOZILLA_BUILD_URL='https://queue.taskcluster.net/v1/task/IhPUOYa4QYG3nfPvexTOyQ/artifacts/public/build/target.tar.bz2' \
      -e MOZHARNESS_SCRIPT='mozharness/scripts/desktop_unittest.py' \
      -e MOZHARNESS_URL='https://queue.taskcluster.net/v1/task/IhPUOYa4QYG3nfPvexTOyQ/artifacts/public/build/mozharness.zip' \
      -e GECKO_HEAD_REPOSITORY='https://hg.mozilla.org/try/' \
      -e MOZHARNESS_CONFIG='mozharness/configs/unittests/linux_unittest.py mozharness/configs/remove_executables.py' \
      -e GECKO_HEAD_REV='35d30e8760f08f24c97b774027ef524c526a2a38' \
      taskcluster/desktop-test:0.4.4 \
      bash /home/worker/bin/test.sh --no-read-buildbot-config '--installer-url=https://queue.taskcluster.net/v1/task/IhPUOYa4QYG3nfPvexTOyQ/artifacts/public/build/target.tar.bz2' '--test-packages-url=https://queue.taskcluster.net/v1/task/IhPUOYa4QYG3nfPvexTOyQ/artifacts/public/build/test_packages.json' '--download-symbols=ondemand' '--mochitest-suite=browser-chrome-chunked' '--total-chunk=7' '--this-chunk=1'

most likely we can put this in some docs somewhere?
I think the template for instructions on how to run locally have been updated.
It features things like "sudo modprobe v4l2loopback" now. Credits probably to garndt.

--
This bug is closed as part of the Great Bugzilla Cleaning Sprint of 2016 by bstack and jonasfj, please reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.