[TV Browser] There should be a pop-up window if user disconnect successfully

VERIFIED FIXED in Firefox OS v2.5

Status

Firefox OS
Gaia::TV::Browser
P3
normal
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: cynthiatang, Assigned: yifan)

Tracking

unspecified
2.6 S2 - 12/4
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
Created attachment 8683666 [details]
[TV]FirefoxAccount_v0.5

============== Gaia Information ==============
commit f17421e9a23b9dbd88c41347f1b9c442a97f48e0
Merge: 06de78d e7dd557
Author: gasolin <gasolin@gmail.com>
Date:   Tue Nov 3 13:37:26 2015 +0800

STR:
 1. Launch Browser
 2. Sign in to Sync
 3. Press "Disconnect" to sign out 

Expected Result:
 - There is a pop-up window that shows "You have signed out successfully."
 - User can press OK/Enter  

Actual Result:
 - No pop-up window

Reference: [TV]FirefoxAccount_v0.5, page 17
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV Firefox Account]

Comment 1

3 years ago
Function missing. Set it to higher priority.
Assignee: nobody → yliao
Priority: P3 → P1

Updated

3 years ago
blocking-b2g: --- → 2.5+
Created attachment 8692413 [details] [review]
[gaia] begeeben:1222016_there_should_be_a_pop_up > mozilla-b2g:master
(Assignee)

Comment 3

3 years ago
Comment on attachment 8692413 [details] [review]
[gaia] begeeben:1222016_there_should_be_a_pop_up > mozilla-b2g:master

The patch displays a sign out successful dialog.
Attachment #8692413 - Flags: review?(ferjmoreno)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED
Attachment #8692413 - Flags: review?(ferjmoreno) → review+
Blocks: 824026
Target Milestone: --- → 2.6 S2 - 12/4
Priority: P1 → P3
(Assignee)

Comment 4

3 years ago
Merged into master:
https://github.com/mozilla-b2g/gaia/commit/ef452b89c76e47d27584c15996aa03da2a716531
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
(Assignee)

Comment 5

3 years ago
Comment on attachment 8692413 [details] [review]
[gaia] begeeben:1222016_there_should_be_a_pop_up > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: A user will not notice when the sign out process is success. 
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=126c01dbc9cb5ab7e997251de07eb3980e373184
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8692413 - Flags: approval-gaia-v2.5?

Comment 6

3 years ago
Comment on attachment 8692413 [details] [review]
[gaia] begeeben:1222016_there_should_be_a_pop_up > mozilla-b2g:master

Approve for TV 2.5
Attachment #8692413 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Updated

3 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → fixed
has problems during uplift:

Tomcats-MacBook-Pro-2:gaia Tomcat$ git cherry-pick 0d97e848e00e67445ab8c3e0f8165b38e5a3ace7
error: could not apply 0d97e84... Bug 1222016 - [TV Browser] There should be a pop-up window if user disconnect successfully
hint: after resolving the conflicts, mark the corrected paths
hint: with 'git add <paths>' or 'git rm <paths>'
hint: and commit the result with 'git commit'
Flags: needinfo?(yliao)
Created attachment 8694014 [details] [review]
[gaia] begeeben:uplift/1222016_2.5 > mozilla-b2g:v2.5
(Assignee)

Comment 9

3 years ago
Patch for v2.5 created. Thanks!
Flags: needinfo?(yliao) → needinfo?(cbook)
https://github.com/mozilla-b2g/gaia/commit/84a4deec32c4be8d2c819e85b5bc8cddda8c7f9c for 2.5
status-b2g-v2.5: affected → fixed
Flags: needinfo?(cbook)

Updated

3 years ago
Depends on: 1223273
(Reporter)

Comment 12

3 years ago
Hi YiFan,
Please watch the video https://youtu.be/Jw0g2tWV_ks . Could you please help check this commit?

STR:
 1. Launch Browser
 2. Go to Menu > Select "Sign in to Sync" > Press OK
 3. Press Back

Actual result:
 - The window "You have signed out successfully" popped up


Expected result:
 - Go back to the previous page after pressing Back


========= Result: Failed ========================
Commit: ef452b89c76e47d27584c15996aa03da2a716531 [ef452b8]
Parents: b04e417b7b, 0d97e848e0
Author: Yi-Fan Liao <yliao@mozilla.com>
Date: 2015年11月30日 GMT+816:10:05秒

Merge pull request #33381 from begeeben/1222016_there_should_be_a_pop_up

Bug 1222016 - [TV Browser] There should be a pop-up window if user disconnect successfully, r=ferjm


========= Result: Passed ========================
Commit: b04e417b7b45ec561a45437bb103b0134eaad44f [b04e417]
Parents: 1c2997569d, 8bc52a7c3f
Author: danhuang1202 <dhuang@mozilla.com>
Date: 2015年11月30日 GMT+816:05:26秒

Merge pull request #33412 from danhuang1202/1223273_revise_fxa_offline_error_message

Bug 1223273 - Revise l10n string of fxa offline error message. r=yifan
Status: RESOLVED → REOPENED
Flags: needinfo?(yliao)
Resolution: FIXED → ---

Updated

3 years ago
Blocks: 1214243

Comment 14

3 years ago
(In reply to Carsten Book [:Tomcat] from comment #13)
> reverted in
> https://github.com/mozilla-b2g/gaia/commit/
> 7ca639a7bb0bacf27f548841c52617bfc0e3b21f

Hi Carston,
Could you also help to update "status-b2g" when you land or revert the patch? ("affected" to "fixed" or the other way around)
It would help help us understand the current patch status on certain release. Thanks!
Flags: needinfo?(cbook)

Updated

3 years ago
status-b2g-v2.5: fixed → affected
(In reply to Josh Cheng [:josh] from comment #14)
> (In reply to Carsten Book [:Tomcat] from comment #13)
> > reverted in
> > https://github.com/mozilla-b2g/gaia/commit/
> > 7ca639a7bb0bacf27f548841c52617bfc0e3b21f
> 
> Hi Carston,
> Could you also help to update "status-b2g" when you land or revert the
> patch? ("affected" to "fixed" or the other way around)
> It would help help us understand the current patch status on certain
> release. Thanks!

yeah sorry missed this here
Flags: needinfo?(cbook)
Created attachment 8701007 [details] [review]
[gaia] begeeben:1222016_only_show_when_logged_in > mozilla-b2g:master
(Assignee)

Comment 17

3 years ago
Comment on attachment 8701007 [details] [review]
[gaia] begeeben:1222016_only_show_when_logged_in > mozilla-b2g:master

This patch checks if a user has logged in before disabling sync. Thanks you for the review!
Flags: needinfo?(yliao)
Attachment #8701007 - Flags: review?(ferjmoreno)
Attachment #8701007 - Flags: review?(ferjmoreno) → review+
(Assignee)

Comment 18

3 years ago
Thanks! Revised according to the comment.
Merged into master: https://github.com/mozilla-b2g/gaia/commit/a07d62b8c3544794e5f7d46bfb39cd97ef59f568
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 19

3 years ago
Comment on attachment 8701007 [details] [review]
[gaia] begeeben:1222016_only_show_when_logged_in > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined: Unexpected logged out successful dialog.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=3a79889ce0ebe005eca701b265086ea9e9198bdf
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8701007 - Flags: approval-gaia-v2.5?

Updated

3 years ago
Duplicate of this bug: 1230588

Comment 21

3 years ago
Comment on attachment 8701007 [details] [review]
[gaia] begeeben:1222016_only_show_when_logged_in > mozilla-b2g:master

Approve for TV 2.5
Attachment #8701007 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
this has conflicts uplifting to 2.5 Tomcats-MacBook-Pro-2:gaia Tomcat$ git cherry-pick c3b50ad965de09fb2278c4f89514622522f18267
error: could not apply c3b50ad... Bug 1222016 - [TV Browser] There should be a pop-up window if user disconnect successfully
hint: after resolving the conflicts, mark the corrected paths
hint: with 'git add <paths>' or 'git rm <paths>'
hint: and commit the result with 'git commit'

can you take a look ?
Flags: needinfo?(yliao)
Created attachment 8703059 [details] [review]
[gaia] begeeben:uplift/1222016_2 > mozilla-b2g:v2.5
(Assignee)

Comment 24

3 years ago
Please try the attached patch for 2.5, thanks.
Flags: needinfo?(yliao) → needinfo?(cbook)
thanks yifan that worked! many thanks for all the help in 2015 !

commited as https://github.com/mozilla-b2g/gaia/commit/37f0119c1c0767962060b25c898c6caaf7f08c04 to 2.5
status-b2g-v2.5: affected → fixed
Flags: needinfo?(cbook)

Comment 28

2 years ago
Verify this issue on the latest build.
1. After signing out, the message "You have signed out successfully." pops up. And then pressing the OK button will back to the Browser Settings page.
2. After signing in and the message "Success! Your Firefox Account is ready to go!" pops up, pressing the Back key and the screen will back to the Browser Settings page.

[Build Info]
Environment: Simulator 2.5.20160215231509
gaia:
https://github.com/mozilla-b2g/gaia/commit/b059a19c4cb615e16174735662199e6769cee393
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/227c6d4926c154167a2214e123253f2c937e4106
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3

[Build Info]
Environment: Simulator 2.6.20160222133739
gaia:
https://github.com/mozilla-b2g/gaia/commit/435a9320454ccc3ffdebff4d5d680f1254a15e26
gecko:
https://hg.mozilla.org/mozilla-central/rev/a9e33d8c48b5ca93ca1937eba4220f681a0f05ec
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.