missing screenshot-on-fail png files when tests fail on task cluster

RESOLVED DUPLICATE of bug 1221553

Status

Taskcluster
General
RESOLVED DUPLICATE of bug 1221553
2 years ago
2 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
when we have failures on buildbot test jobs, we have a link with a screenshot.  this is because we take a screenshot and put it in the blobber upload directory.  when the test finishes we upload the files in the directory to s3 and then put fancy links in treeherder.

Here is a snippet from a buildbot failed job (http://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-inbound-linux64/1446731917/mozilla-inbound_ubuntu64_vm_test-mochitest-e10s-browser-chrome-1-bm125-tests1-linux64-build56.txt.gz):
06:44:09     INFO -  (blobuploader) - INFO - Uploading /builds/slave/test/build/blobber_upload_dir/mozilla-test-fail-screenshot_SoONVP.png ...
06:44:09     INFO -  (blobuploader) - INFO - Using https://blobupload.elasticbeanstalk.com
06:44:09     INFO -  (blobuploader) - INFO - Uploading, attempt #1.
06:44:11     INFO -  (blobuploader) - INFO - TinderboxPrint: <a href='http://mozilla-releng-blobs.s3.amazonaws.com/blobs/mozilla-inbound/sha512/276a451fae6d1f2e8771b0251d9be4fa331c133e79b71ff401fe7bfc0a8f914b74b26f9fc79c500e7cbf98e20615aece295bebcae6ffaee0704caeabf42ddd8a'>mozilla-test-fail-screenshot_SoONVP.png</a>: uploaded
06:44:11     INFO -  (blobuploader) - INFO - Blobserver returned 202. File uploaded!


On a task cluster job I don't see that, instead I see (https://tools.taskcluster.net/task-inspector/#CgkRCrP6SnO6g7aXyF7rvw/0):
11:07:19     INFO - Running post-run listener: _upload_blobber_files
11:07:19  WARNING - Blob upload gear skipped. Missing cmdline options.
11:07:19     INFO - Copying logs to upload dir...
11:07:19     INFO - mkdir: /home/worker/workspace/build/upload/logs
11:07:19  WARNING - returning nonzero exit status


we need to figure out how to get this information upon failure.
This might just be a dupe of bug 1221553.
(Reporter)

Comment 2

2 years ago
ok, I have verified on a local docker instance that the screenshot sits in the MOZILLA_UPLOAD_DIR as expected, so this is probably an issue with blobber uploads, aka bug 1221553.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1221553
You need to log in before you can comment on or make changes to this bug.