Settings-> Cellular & Data, confirmation dialog does not show the detailed description

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: njpark, Assigned: scottwu)

Tracking

({late-l10n, regression})

unspecified
ARM
Gonk (Firefox OS)
late-l10n, regression

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

Attachments

(7 attachments)

(Reporter)

Description

2 years ago
Created attachment 8683795 [details]
2015-11-05-12-59-22_missing.png

This happens in latest 2.5 and 2.6 build
STR:
Open Settings, go to Cellular & Data
Enable Data Connection
Expected: Dialog shows up, with the detailed description.
Actual: Dialog does not show the detailed description, although WebIDE shows the section for the message, which is empty.
Enable Data Roaming
Expected: Dialog shows up, with the detailed description.
Actual: Dialog does not show the detailed description, although WebIDE shows the section for the message, which is empty.

See attached screenshot.  *_missing is from the latest build, and ones without _missing suffix is from the build a few days ago.
(Reporter)

Comment 1

2 years ago
Created attachment 8683796 [details]
2015-11-05-13-38-07_missing.png
(Reporter)

Comment 2

2 years ago
Created attachment 8683797 [details]
2015-11-05-13-50-56.png
(Reporter)

Comment 3

2 years ago
Created attachment 8683798 [details]
2015-11-05-13-51-05.png
(Reporter)

Updated

2 years ago
Component: Gaia::UI Tests → Gaia::Settings
(Reporter)

Updated

2 years ago
Keywords: regression
(Reporter)

Updated

2 years ago
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
[Blocking Requested - why for this release]: It is really important to warn users about possible extra costs or charges
blocking-b2g: --- → 2.5?
Scott, could you take it a look?
Flags: needinfo?(scwwu)
(Assignee)

Comment 6

2 years ago
Yes I'll fix this. Thanks.
Assignee: nobody → scwwu
Flags: needinfo?(scwwu)
Duplicate of this bug: 1223610
Keywords: late-l10n
Created attachment 8685913 [details] [review]
[gaia] scottwu:1222117-cellular-data-confirmation > mozilla-b2g:master
(Assignee)

Comment 9

2 years ago
Comment on attachment 8685913 [details] [review]
[gaia] scottwu:1222117-cellular-data-confirmation > mozilla-b2g:master

Dumb mistake on my part. Accidentally removed the old string when fixing Bug 1218705..
Attachment #8685913 - Flags: review?(gasolin)
Attachment #8685913 - Flags: review?(gasolin) → review+
(Assignee)

Comment 10

2 years ago
Thanks. Merged to master.
Hey - a few things:
* this is late-l10n for 2.5, and we're way past string freeze (which was Nov. 2nd). 
* Patch landed on master 7 days ago, but still no uplift asked on 2.5 although this breaks 2.5 string freeze
* Do we really need this on 2.5? RelMan has the last word about what gets to land there at this point, but I'd like to see if there's anyway we can *not* break string freeze on 2.5 at this point. 
* BTW please remember to add the "late-l10n" keyword next time a patch breaks string freeze, as this is the usual process.
Thanks
Comment on attachment 8685913 [details] [review]
[gaia] scottwu:1222117-cellular-data-confirmation > mozilla-b2g:master

[Approval Request Comment] add deleted string back, its same string in previous versoin
[Bug caused by] (feature/regressing bug #): bug 1218705
[User impact] if declined: an blank dialog content
[Testing completed]: v
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: its same string in previous versoin, so supposedly we can just put them back (?)


Sorry for missing the procedure.
Attachment #8685913 - Flags: approval-gaia-v2.5?
(In reply to Fred Lin [:gasolin](OOO till 11/22) from comment #12)
> [String changes made]: its same string in previous versoin, so supposedly we
> can just put them back (?)

It's not how things work, it should be considered as two new strings.
(Assignee)

Comment 14

2 years ago
Is there anything we can do to help?

Isabel, what do you think?
Flags: needinfo?(irios.mozilla)
Has this been verified on Master? Can you please add a screen of verification on master?

Its bad to not have a message for the user about cellular data being turned on.
I know it is late and but in my opinion this string should be included in 2.5 since it affects how users are warned about posible extra-charges.
Flags: needinfo?(irios.mozilla)
(Assignee)

Comment 17

2 years ago
Created attachment 8690011 [details]
confirmation.png

Here's the screenshot for verification.
(Assignee)

Comment 18

2 years ago
Created attachment 8690012 [details]
version.png

Version info.
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1227898
(Assignee)

Comment 20

2 years ago
A side effect of this bug has been reported in Bug 1227898, where the message from a previous dialog will be shown when data confirmation dialog is displayed. This could potentially be very confusing for users.

It's still best to have it on 2.5 branch, perhaps even untranslated? Again, sorry for the trouble caused by this patch.
blocking-b2g: 2.5? → ---
Comment 20 suggests we would hardcode these strings. Please, let's not do that - worst case scenario is better to break string freeze here. 
Also, as stated in comment 11, if this gets approved to land on 2.5 this is going to break string freeze by a LOT (it was Nov 2nd). It's been almost a month that this bug has been filed - please keep in mind that we're working with volunteer translators and that breaking string freeze means breaking our pact with them. At this point, having to announce them there are still string changes on 2.5 one month after string freeze kinda sucks. Thanks!
Comment on attachment 8685913 [details] [review]
[gaia] scottwu:1222117-cellular-data-confirmation > mozilla-b2g:master

Thank you Delphine. Appreciate the concern here. Not approved for 2.5 uplift. 

Also, please note foxfooders are getting updates from master/b2g-ota branch. So this is already out for foxfooders in last update. Thanks
Attachment #8685913 - Flags: approval-gaia-v2.5?
(Assignee)

Comment 23

2 years ago
Patch already in master. Marking it as resolved. 
Thanks all.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.