Add Persian (fa) to master and 2.5 builds

RESOLVED FIXED in Firefox OS v2.5

Status

Firefox OS
Gaia
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: tchevalier, Assigned: tchevalier)

Tracking

(Blocks: 1 bug)

unspecified
2.6 S1 - 11/20
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Let’s add this locale to master and 2.5. Repos are ready.

I assume it makes sense for Persian to have ar and en keyboards enabled by default, like for Arabic.

Behavior with this patch will be when choosing Persian on FTU:
- Enable ar and en keyboard layouts
- ar will be the default one

Sara, is that ok, or you would like something else?
Note that Arabic keyboard does not have a dictionary yet, so you won’t see Arabic word suggestions when typing.

Also note that this can be changed at any time, and we’ll be able to add a specific layout for Persian later, but we need at least one default layout for now.

Last thing, is the locale name correctly spelled? "فارسی" this is what users will see in Settings.
Flags: needinfo?(sara.mansouri)

Comment 1

2 years ago
Ok great news!
Yes, Please use english keyboard(en) enabled by default.
Yes the locale name is correctly spelled: "فارسی" 

Thank you!

Comment 2

2 years ago
Created attachment 8686682 [details] [review]
[gaia] TheoChevalier:add-persian > mozilla-b2g:master
(Assignee)

Comment 3

2 years ago
Thanks, updated the Pull Request to enable en layout.

Stas, if you can give it a look when you have the time :)
Flags: needinfo?(sara.mansouri)
(Assignee)

Updated

2 years ago
Attachment #8686682 - Flags: review?(stas)
Comment on attachment 8686682 [details] [review]
[gaia] TheoChevalier:add-persian > mozilla-b2g:master

Technically this looks good, r=me.  It's a pity we don't have a Farsi keyboard layout.  Could you file a bug about it?
Attachment #8686682 - Flags: review?(stas) → review+
(Assignee)

Comment 5

2 years ago
Thanks Stas :)

Looks like layout + word list are being worked out in bug 1033185
Keywords: checkin-needed

Comment 6

2 years ago
There are already two different layouts of keyboard for Persian language, one of 10 letters length (more suitable for computer-phone) and one of 11 letters length (more suitable for tablet, would be suitable for computer-phone on landscape also if such option was possible, but I don;t know how to implement that).
A word list is prepared also but I have to find out how to upload it to github. I didn't manage to make it a dictionary yet.
see here https://bugzilla.mozilla.org/show_bug.cgi?id=1033185 .
https://github.com/mozilla-b2g/gaia/commit/0630ebd286a0f2b5f97b7cc8c1d65f948c8c6fc9
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.6 S1 - 11/20
(Assignee)

Comment 8

2 years ago
Comment on attachment 8686682 [details] [review]
[gaia] TheoChevalier:add-persian > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a
[User impact] if declined: No Persian language
[Testing completed]: master builds
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: n/a

Persian locale is ready for 2.5, we would like to ship it.
Attachment #8686682 - Flags: approval-gaia-v2.5?

Updated

2 years ago
Keywords: checkin-needed
Hi Mahe: we have planned to test Persian during the 2.5 localization run. Could you please approve this so it can land on 2.5? Testing started today, would be great if we could get to this during the week :) thanks!
Flags: needinfo?(mpotharaju)
Comment on attachment 8686682 [details] [review]
[gaia] TheoChevalier:add-persian > mozilla-b2g:master

Approved for 2.5.

Thank you.
Attachment #8686682 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
Flags: needinfo?(mpotharaju)
(Assignee)

Comment 11

2 years ago
Thanks. Assuming the master PR can be cherry-picked onto 2.5 (files are identical), adding checking-needed.
Keywords: checkin-needed
uplifted in https://github.com/mozilla-b2g/gaia/commit/28d63cf3bdc4417f7ad8cab2230f096bf9f6d3b5 to 2.5
status-b2g-v2.5: --- → fixed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.