Scrolling will not function briefly the first time an item picker list is opened after booting.

VERIFIED DUPLICATE of bug 1224128

Status

VERIFIED DUPLICATE of bug 1224128
3 years ago
3 years ago

People

(Reporter: Marty, Assigned: timdream)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.6+, b2g-v2.2 unaffected, b2g-v2.5 unaffected, b2g-master verified)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8683932 [details]
logcat_20151105_1603.txt

Description:
The first time a scrollable item picker list is opened after booting up, the user will not be able to scroll for about 1 second (sometimes as short as 1/2 second to longer than 3 seconds).  This only seems to happen the first time one of these lists is opened and used.

Idling on the list before attempting to scroll does not seem to affect this issue.  It appears that the scroll bar, visible on the right side of the screen, does not become visible until this issue resolves itself.

This is easily seen in Settings, attempting to scroll the language list. This is also easily visible in the time zone lists of Date and Time, in both Settings and the FTU.

When this issue occurs, the user can see the divider lines between list items flicker, as if the list items were being highlighted instead of the list scrolling.

Note:
It seems that this issue happens more frequently when trying to scroll down rather than scrolling up, but has been seen to occur when scrolling in both directions.

Repro Steps:
1) Update a Flame to 20151104030208
2) After freshly booting the device, open the Settings app.
3) Navigate to Languages and open the language picker.
4) Attempt to scroll down the list.

Actual:
The list item divider lines will flicker, but the list will not scroll for one or more seconds.

Expected:
The list will scroll the first time scrolling is attempted.

Environmental Variables:
Device: Aries 2.6
Build ID: 20151030120435
Gaia: 91cac94948094cfdcd00cba5c6483e27e80cb3b0
Gecko: c2534acb485963331d67bbc5c07f0d862ed56bf5
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: logcat, Video (URL)
(Reporter)

Comment 1

3 years ago
This issue DOES occur on the latest Flame 2.6, and 2.5 build.
The list item divider lines will flicker, but the list will not scroll for one or more seconds.

Environmental Variables:
Device: Flame 2.6
BuildID: 20151105030203
Gaia: 607b9c5db7fdbbafc16a572e7c319baa266a3372
Gecko: 59c648a3f95524cb1ee42f2306c1db2698d35258
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20151105004500
Gaia: 47da49f8206788d70d834c3a63d9245d50c89103
Gecko: 5c9fd135d4309239794126f1942d6e7aa8b3579c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

This issue does NOT occur on the latest Flame 2.2 build.
The list will scroll the first time scrolling is attempted.

Environmental Variables:
Device: Flame 2.2
BuildID: 20151105032504
Gaia: 885647d92208fb67574ced44004ab2f29d23cb45
Gecko: 9d91dfad5e16
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

Regression which could lead to end user frustration.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Contact: pcheng
b2g-inbound regression window:

Last Working
Device: Flame
BuildID: 20151019000932
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: 7aa88c466932c343fa40f12afb1bac82d9bd7385
Version: 44.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

First Broken
Device: Flame
BuildID: 20151019010933
Gaia: 043b7c9231335e2257588005ab9c13dcdb7fc3c4
Gecko: ee9f3c9bb56c9135af0263b65eb4312604bfa772
Version: 44.0a1
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Last Working Gaia First Broken Gecko - no repro
Gaia: f75bd584aca0a751a5bed115800250faa8412927
Gecko: ee9f3c9bb56c9135af0263b65eb4312604bfa772

Last Working Gecko First Broken Gaia - repro
Gaia: 043b7c9231335e2257588005ab9c13dcdb7fc3c4
Gecko: 7aa88c466932c343fa40f12afb1bac82d9bd7385

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/f75bd584aca0a751a5bed115800250faa8412927...043b7c9231335e2257588005ab9c13dcdb7fc3c4

This issue is likely caused by changes made in Bug 1207485.
Blocks: 1207485
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: regressionwindow-wanted
Tim this issue seems to have been caused by the changes for bug 1207485.  Can you please take a look?
Flags: needinfo?(jmercado) → needinfo?(timdream)
Interesting bug. Let's backout bug 1207485 first to take this bug off 2.5 blockers.
Assignee: nobody → timdream
Status: NEW → ASSIGNED
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(timdream)
bug 1207485 reverted from v2.5.
blocking-b2g: 2.5+ → 2.6+
status-b2g-v2.5: affected → unaffected
I can confirm the patch in bug 1224128 fix this bug too. I assume this bug is cause by the fact we are drawing/rendering the value selector twice.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224128
According to https://bugzilla.mozilla.org/show_bug.cgi?id=1224128#c11, I change the status to "resolved verified".
Status: RESOLVED → VERIFIED
status-b2g-master: affected → verified
You need to log in before you can comment on or make changes to this bug.