Do not show system tray icon when manually checking mail.

VERIFIED FIXED in mozilla0.9.9

Status

SeaMonkey
MailNews: Message Display
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Stephen Moehle, Assigned: Scott MacGregor)

Tracking

Trunk
mozilla0.9.9
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

16 years ago
Please do not show the system tray icon for new mail when manually checking
mail.  I am finding it distracting when checking for new mail by clicking the
Get Msgs button, and the icon appears in the system tray.  This is fallout from
bug 119344.

Mozilla trunk build 2002-01-28-03 on Win2000.
Created attachment 66759 [details]
from reporter via mail

"I cant save the mail in the mail client, because then the status bar starts
turning and turning  and the mail never shows up ...
thisone is taken from the mailsystem of a SuSE 6.4 system."


btw: i had no problems on win2k and 20020128.. to read the mail (mozilla opened
the attachment inline)
ARGH- Please ignore the last comment / wrong bug.

Updated

16 years ago
Severity: normal → enhancement
QA Contact: esther → sheelar

Comment 3

16 years ago
In 4.x when you manually get message we do not display the flag on the mail 
icon in the system tray. This is the behavior with 4.x nsnotify.
Since 6.x mail notification is different I will leave it jglick to decide as to 
how the behavior should be.  
For now confirming..
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
Reassigning bug to mscott 
Assignee: sspitzer → mscott
(Assignee)

Comment 5

16 years ago
We should only show the biff icon in the system tray if biff went off and not
when you click the get new mail button. I just hadn't gotten around to doing
that yet. Patch coming up to make us match 4.x behavior. 
Severity: enhancement → normal
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla0.9.9
(Assignee)

Comment 6

16 years ago
Created attachment 67334 [details] [diff] [review]
possible fix

Comment 7

16 years ago
Correct me, I could be wrong but I thought biff is a per server thing then 
this attribute should be on nsIMsgIncomingServer instead of nsIMsgFolder. 


(Assignee)

Comment 8

16 years ago
I'm storing it on the root folder only of each account because the folders are
the classes which get notified when the url is finished. Although it would be
easy to modify the folder code to get the incoming server and set / clear the
flag on the server. lemme think about that. 
(Assignee)

Comment 9

16 years ago
Created attachment 67498 [details] [diff] [review]
new patch, moves the boolean into the incoming server

I liked your suggestion Navin. Nice catch. I moved the flag over to the
incoming server. This new patch now reflects that.
Attachment #67334 - Attachment is obsolete: true

Comment 10

16 years ago
minor changes... (sorry, I was about to note them just when you posted new 
patch)

you should QI for urlListener from inbox rather than rootFolder here in
Pop3IncomingServer 

+urlListener = do_QueryInterface(rootMsgFolder);

enclose these 4 lines in nsLocalMailFolder.cpp

if (inbox)
{
+
+  nsCOMPtr<nsIMsgIncomingServer> server;
+  GetServer(getter_AddRefs(server));
+  if (server)
+    server->SetPerformingBiff(PR_FALSE);
+
}


could use this if -

if (mDatabase && (mFlags & MSG_FOLDER_FLAG_INBOX))
     {

In nsImapIncomingServer you don't need to get nsIFolder and then QI for 
nsIMsgFolder, GetRootMsgFolder does that

+
nsCOMPtr<nsIFolder> rootFolder;
+
rv = GetRootFolder(getter_AddRefs(rootFolder));
+
if(NS_SUCCEEDED(rv))
+
{
+    nsCOMPtr<nsIMsgFolder> rootMsgFolder = do_QueryInterface(rootFolder);
+
	if(rootMsgFolder)
+    {

Just add 
SetPerformingBiff(PR_TRUE);

do that and r=naving. 




(Assignee)

Comment 11

16 years ago
Created attachment 67516 [details] [diff] [review]
updated patch with navin's comments
Attachment #67498 - Attachment is obsolete: true

Comment 12

16 years ago
Comment on attachment 67516 [details] [diff] [review]
updated patch with navin's comments

looks good, r=naving.
Attachment #67516 - Flags: review+

Comment 13

16 years ago
good review, Navin. Scott, there's an easy way to tell if any get new mail url
is for biff or not - if there's no nsIMsgWindow associated with the url, it's
biff. I'm not sure if this will allow you to simplify this patch or not - let me
know if you want me to sr this as is, or rework it with that info.
(Assignee)

Comment 14

16 years ago
Created attachment 67774 [details] [diff] [review]
changes to the folder classes

This last patch just shows the changes to imap and local mail folders showing
the check for the absence of a mail window in the url.

Comment 15

16 years ago
Comment on attachment 67774 [details] [diff] [review]
changes to the folder classes

sr=bienvenu
Attachment #67774 - Flags: superreview+

Comment 16

16 years ago
Comment on attachment 67516 [details] [diff] [review]
updated patch with navin's comments

sr=bienvenu
Attachment #67516 - Flags: superreview+
(Assignee)

Comment 17

16 years ago
fixed. be sure to QA both pop and imap.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 18

16 years ago
I think when we are downloading msgs on biff - pop3, we should pass
valid msgWindow, We need to throw alert if write fails to the inbox. 
I can spin-off a bug or you can just pass msgWindow in 

GetNewMail(...

QA Contact: sheelar → stephend
Depends on: 122626
QA Contact: stephend → gchan
QA Contact: gchan → stephend
Verified FIXED with POP3 (qatest36@netscape.com) and IMAP
(stephend@netscape.com) using:

Windows XP - 2002-04-04-03
Windows 2000 - 2002-04-04-03
Windows 98/ME - 2002-04-04-03
Windows NT 4.0 - 2002-04-04-03

Thanks to Gary for the NT 4.0 verification...

Using the File | Get New Messages, context-clicking and doing 'Get New Message
for Account' at the server level, and doing a GetMsg all do not display the mail
notification icon.  We only do this when biff goes off at the interval specified
in Edit | Mail & Newsgroups | Server Settings | Check for new messages every x
minutes.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.