Popular page is loaded after an “open/close” cycle of Categories drop-down

VERIFIED FIXED in 2015-11-17

Status

Marketplace
Consumer Pages
P2
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: ValentinaP, Assigned: spasovski)

Tracking

Avenir
2015-11-17
x86_64
Windows 7
Points:
---

Details

(URL)

(Reporter)

Description

2 years ago
Steps to reproduce:
1. Load MP-dev homepage https://marketplace-dev.allizom.org/
2. Click “Categories” option
3. Click “Categories” option again to close it

Expected results:
There are no display or layout issues. The user is in homepage.

Actual results:
After closing categories drop-down the user is taken to Popular page.

Notes/Issues:
Issue is happening from any page.
Also the “Categories” option is moving when hovering over. (because is a very small thing, that can be seen following this steps, I did not log another issue)
Verified on MP-dev FF45(Win 7). Issue is reproducing on MP-dev, stage and production.
Screencast for this issue: http://screencast.com/t/Ic8z65agGpYU
(Reporter)

Comment 1

2 years ago
Issue is reproducing only if, at step #3, the "Categories" title inside the drop-down list is clicked. (the one near the arrow). 
Sorry for misleading.
We shouldn't show that second control on desktop.
Priority: -- → P2
Target Milestone: 2015-11-10 → 2015-11-17
(Assignee)

Comment 3

2 years ago
On mobile the "categories" link is supposed to take you to the popular page. I agree we shouldn't show that link on desktop though so that fix was added:

https://github.com/mozilla/fireplace/commit/32afcc8
Assignee: nobody → dspasovski
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

2 years ago
Verified as fixed on MP-dev FF45(Win 7).
Postfix screenshot: http://screencast.com/t/rl8dmEtxFh2
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

2 years ago
Could you, please, cherry-pick this fix, because is now in prod. (http://screencast.com/t/L2HHSJA4)
Thank you!
Flags: needinfo?(dspasovski)
(Assignee)

Comment 6

2 years ago
It's too late to cherry-pick for this week, and I don't think the bug is too terrible since the design team intended the top option to take you to the 'all categories' page - which is really just '/popular'.

It's not really my call though if someone wants to do an off-schedule push for this. I'd rather see one for the more button touch area inconsistency.
Flags: needinfo?(dspasovski)
You need to log in before you can comment on or make changes to this bug.