bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[TV Browser] TV should keep the focus on the account field after pressing the X button

RESOLVED FIXED

Status

Firefox OS
Gaia::TV::Browser
P3
normal
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: cynthiatang, Assigned: yifan)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed)

Details

(Whiteboard: [ft:conndevices][partner-cherry-pick])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Commit 1fb7e4b7904d577a1859b91269a85b363ddc2836
Merge: 079ead4 dd4a903
Author: gasolin <gasolin@gmail.com>
Date:   Fri Nov 6 10:30:49 2015 +0800

STR:
 1. Launch Browser
 2. Move cursor to Menu icon and press OK 
 3. Select "Sign in to Sync" and press OK
 4. Enter "abcd" > Press "Right" > Press OK

Expected Result:
 - The X button should be hidden
 - TV should keep the focus on the account field
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=TV Firefox Account]

Comment 1

3 years ago
What is the actual result?
Flags: needinfo?(ctang)

Updated

3 years ago
blocking-b2g: --- → 2.5?
(Assignee)

Comment 2

3 years ago
(In reply to Evelyn Hung [:evelyn] from comment #1)
> What is the actual result?

The focus will still remain on the X button.
Assignee: nobody → yliao
Depends on: 1221439
Whiteboard: [ft:conndevices] → [ft:conndevices][partner-cherry-pick]
(Reporter)

Comment 3

3 years ago
Actual Result:
 - It doesn't keep the focus on the account field. User have to move the cursor to the account field.
 - The X button would not be hidden
Flags: needinfo?(ctang)
Created attachment 8692733 [details] [review]
[gaia] begeeben:1222366_tv_should_keep_the_focus > mozilla-b2g:master
(Assignee)

Comment 5

3 years ago
Comment on attachment 8692733 [details] [review]
[gaia] begeeben:1222366_tv_should_keep_the_focus > mozilla-b2g:master

Sean could you please help to review the patch? Thank you!
Attachment #8692733 - Flags: review?(selee)
(Assignee)

Updated

3 years ago
Status: NEW → ASSIGNED

Updated

3 years ago
blocking-b2g: 2.5? → 2.5+
Comment on attachment 8692733 [details] [review]
[gaia] begeeben:1222366_tv_should_keep_the_focus > mozilla-b2g:master

LGTM. Thanks!
Attachment #8692733 - Flags: review?(selee) → review+
(Assignee)

Comment 7

3 years ago
Merged into master:
https://github.com/mozilla-b2g/gaia/commit/a33933d4acef32d276b4024b93c2985b5ce1843c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8692733 [details] [review]
[gaia] begeeben:1222366_tv_should_keep_the_focus > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 1194108
[User impact] if declined: Cumbersome UI
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=925837deac35e950f71bc821df4bf9fa51f2cec5
[Risk to taking this patch] (and alternatives if risky): none
[String changes made]: none
Attachment #8692733 - Flags: approval-gaia-v2.5?

Comment 9

3 years ago
Comment on attachment 8692733 [details] [review]
[gaia] begeeben:1222366_tv_should_keep_the_focus > mozilla-b2g:master

Approve for TV 2.5
Attachment #8692733 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
You need to log in before you can comment on or make changes to this bug.