When user quickly taps "import all" several times in view page, the prompt "One duplicated Contact merged" will increase from bottom of screen as the number of your tap grows.

VERIFIED FIXED

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Carrie.Yang Leave from Mozilla, Assigned: ferjm)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 disabled, b2g-v2.5 verified, b2g-master verified)

Details

Attachments

(5 attachments)

(Reporter)

Description

2 years ago
[1.Description]:
[Aries kk v2.6 ][Flame kk v2.6 & v2.5]Launch SMS app to edit a new message, attach a contact file via selecting "Communications" to select a contact to add. When viewing the contact attached, if user quickly taps "import all" several times at this view, the prompt "One duplicated Contact merged No duplicated Contact merged" will increase from bottom of screen as the number of your tapping grows. 

See Attachments: Aries_v2.6.3gp and logcat_1405.txt and Import_error.png
Found Time: 14:05

[2.Testing Steps]: 
Precondition: Have at least one contact in Contacts app.
1. Launch SMS app.
2. Tap on the Compose icon .
3. Add attachment by selecting "Communications" and then select a contact.
4. Tap the contact , then enter the view page.
5. Quickly tap "Import all" icon some times, then observe the screen.

[3.Expected Result]: 
5. Only the prompt "Imported one contact   One duplicated Contact merged" should be shown, no matter how many times you have tapped "Import all".
 
[4.Actual Result]: 
5. These prompt messages "Imported one contact",  "One duplicated Contact merged", "No duplicated Contact merged" will increase and it can even fill the entire screen as the number of your tap grows.

[5.Reproduction build]: 
Device: Aries kk v2.6 master  ( Affected )     
Build ID               20151105235624
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko 
Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151105.231433
Firmware Date          Thu Nov  5 23:14:41 UTC 2015
Bootloader             s1                                                                                    
Device: Flame kk v2.6 master 512mb ( Affected )
Build ID               20151105150203
Gaia Revision          f39a7a827c0c0f48087ff3ead94f61ae22523919
Gaia Date              2015-11-05 18:52:32
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/dae6c2b8fef8a2f504baab5dae7ccd59d57a1d9d
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.182857
Firmware Date          Thu Nov  5 18:29:10 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame kk v2.5 master 512mb ( Affected )
Build ID               20151105004500
Gaia Revision          47da49f8206788d70d834c3a63d9245d50c89103
Gaia Date              2015-11-03 21:48:23
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/5c9fd135d4309239794126f1942d6e7aa8b3579c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.043012
Firmware Date          Thu Nov  5 04:30:24 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:Flame kk v2.2  (Diasbled)
Build ID               20151105032504
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/9d91dfad5e16
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151105.064912
Firmware Date          Thu Nov  5 06:49:23 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test
(Reporter)

Comment 1

2 years ago
Created attachment 8684123 [details]
Aries_v2.6.3gp
(Reporter)

Comment 2

2 years ago
Created attachment 8684124 [details]
logcat_1405.txt
(Reporter)

Comment 3

2 years ago
Created attachment 8684125 [details]
Import_error.png
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → disabled
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
This happens in Contacts.

What does "disabled" mean ?
Component: Gaia::SMS → Gaia::Contacts
[Blocking Requested - why for this release]: Nominating since the behaviour when tapping on it is really bad and confusing for user.

I have checked in v2.2, there a contact is attached and tapping on it and on View option shows the contact in details view. The behaviour is different than in 2.5 and 2.6

For 2.5 and 2.6, once the contact is attached and we want to see its details tapping on it, there is the import option and tapping on it makes this bugs appear.

Should this import option be available when creating the message and the attached contact is one already in our contact list?
blocking-b2g: --- → 2.5?
(In reply to Julien Wajsberg [:julienw] from comment #4)
> This happens in Contacts.
> 
> What does "disabled" mean ?

"Disable" should mean function is not supported. For this bug, when user tap the contact as STR 4 on FxOS v2.2, it will show the contact edit view, which is different with v2.5/master.
Triage meeting: blocking

We need to fix the bad user experience. Isabel will be opening a new bug for request a feature where sms knows that is opening something that already comes from the phone.
blocking-b2g: 2.5? → 2.5+
New bug for the requested feature: Bug 1224142
Assignee: nobody → ferjmoreno
Status: NEW → ASSIGNED
Created attachment 8690440 [details] [review]
[gaia] ferjm:bug1222375.importall.contacts > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8690440 - Flags: review?(francisco)
Comment on attachment 8690440 [details] [review]
[gaia] ferjm:bug1222375.importall.contacts > mozilla-b2g:master

LGTM
Attachment #8690440 - Flags: review?(francisco) → review+
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
This bug is already solved in 2.6
Aries
BuildID:201511250136653
Gaia:37250b12
Platform: 45.0a1

But NOT in 2.5, I am still able to reproduce there:
Flame
BuildID:20151125230113
Gaia:93b8bf2d
Platform: 44.0a2


Francisco is it necessary to ask for the uplift? Thanks!
Flags: needinfo?(francisco)
Yes; Fernando, can you do the uplift request ?
Flags: needinfo?(francisco) → needinfo?(ferjmoreno)
We need to ask for approval for 2.5.

Also we should do the uplift to nga branch.
(Assignee)

Comment 15

2 years ago
Comment on attachment 8690440 [details] [review]
[gaia] ferjm:bug1222375.importall.contacts > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Contacts.
[User impact] if declined: Bad UX.
[Testing completed]: Manual testing.
[Risk to taking this patch] (and alternatives if risky): Very low.
[String changes made]: None.
Flags: needinfo?(ferjmoreno)
Attachment #8690440 - Flags: approval-gaia-v2.5?
status-b2g-master: affected → fixed
Comment on attachment 8690440 [details] [review]
[gaia] ferjm:bug1222375.importall.contacts > mozilla-b2g:master

Approved for 2.5. Fairly small fix. 

Please uplift. Thanks
Attachment #8690440 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+
(Reporter)

Comment 19

2 years ago
This bug has been verified as pass on latest build of Flame KK v2.5 512mb and Aries KK v2.5 by the STR in comment 0.
Actual results: Only the prompt "Imported one contact   One duplicated Contact merged" is shown, no matter how many times you have tapped "Import all".
See attachment: Verified_Flame_v2.5.3gp.
Reproduce rate: 0/10.

Device: Flame KK v2.5 512mb  (Pass)
Build ID               20151202161543
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/90cfa13f91aa4bb811f6f651e2e3ad7d2bddbb3d
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151202.152541
Firmware Date          Wed Dec  2 15:25:51 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK v2.5 (Pass)
Build ID               20151202162902
Gaia Revision          2d54c29f429bed790b5d8284633812dc2b782518
Gaia Date              2015-12-02 14:41:15
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/90cfa13f91aa4bb811f6f651e2e3ad7d2bddbb3d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151202.153536
Firmware Date          Wed Dec  2 15:35:44 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.5: fixed → verified
status-b2g-master: fixed → verified
(Reporter)

Comment 20

2 years ago
Created attachment 8695077 [details]
Verified_Flame_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.