"Request Desktop Site" feature should use the last user initiated location change and not just reload current address with desktop mode

RESOLVED DUPLICATE of bug 1027143

Status

()

RESOLVED DUPLICATE of bug 1027143
3 years ago
3 years ago

People

(Reporter: jhford, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Some pages switch between mobile and desktop mode using redirects, it seems.  An example is the Huawei mobile hotspot administration interface.

When I use Firefox for Android, I have the following interaction:

1. type in 192.168.8.1
2. router redirects me to 192.168.8.1/html/small/index.html
3. i select "Request Desktop Site"
4. firefox for android loads http://192.168.8.1/html/small/index.html in desktop mode

The result is that my page never actually switches to the desktop mode until I re-enter my URL (192.168.8.1), at which point I get to the desktop interface.

What I expect to happen is:

1. type in 192.168.8.1
2. router redirects me to http://192.168.8.1/html/small/index.html
3. i select "Request Desktop Site"
4. firefox for android loads 192.168.8.1 in desktop mode
5. router admin page redirects me to http://192.168.8.1/html/index.html


What would be really good is if the "Request Desktop Site" feature reloaded the page using the last *user* initiated location (i.e. location bar entry or clicking a link) change instead of the contents of the URL bar.
Summary: show desktop version feature should use the last user initiated location change and not just reload current address with desktop mode → "Request Desktop Site" feature should use the last user initiated location change and not just reload current address with desktop mode
See Also: → bug 1109675
We already do this for HTTP redirects, but there are some cases that don't work (see https://bugzilla.mozilla.org/show_bug.cgi?id=1027143#c4).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1027143
You need to log in before you can comment on or make changes to this bug.