Closed Bug 1222432 Opened 8 years ago Closed 8 years ago

URL bar dropdown is now shorter

Categories

(Firefox :: Address Bar, defect)

42 Branch
All
Windows
defect
Not set
minor

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gollam6, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Attached image firefox_bug.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

1. I created a new, clean Firefox profile.
2. I opened ~10 different web pages.
3. I clicked on the down arrow, at the right end of the URL bar.


Actual results:

The URL bar showed up, but there is now a scrollbar on the right side of it, although the items could've easily fit the screen.


Expected results:

All the items should be displayed, without a scrollbar, just like in the previous versions.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Has Regression Range: --- → no
Has STR: --- → yes
Component: Untriaged → Location Bar
Keywords: regression
I've noticed that this does not occur every time. It may be related to screen resolutions. It is happening to me on 1280x800, but not on 1680x1050.
I confirm that this affects me as well. It is very annoying when using trackpoint on a laptop, because without a wheel it is hard to scroll down the list.

It this is an intentional change, I think that it should be made configurable.
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:42.0) Gecko/20100101 Firefox/42.0
20151029151421

Following the STR at comment 0, the dropdown size becomes normal after restarting Firefox.
I have noticed a change since FF 42 which may be related to this bug. I'm on Win7 x86.

1. Start FF and, *before using autocomplete*, click on the down arrow on the right of the location bar. The list of most visited sites appears, showing all 12 entries without scrollbar. This has always been so. It remains so even after using autocomplete, in all tabs, until you restart FF (or close the affected window).

2. Restart FF (or open a new window), this time use autocomplete to return to a visited url *before clicking the down arrow*. Then click the down arrow. The list of most visited sites now shows only the top 6, with scrollbar (as shwon in attachment 8684218 [details]). This is new in 42. It remains so in all tabs of the affected window until you close it or restart FF.

So, it seems that in 42 the appearance of the list of most visited sites in a window depends on which feature you use first in that window: autocomplete or dropdown.
I can't reproduce comment 4:

1. Start Firefox.
2. Click the location bar's dropdown arrow.
3. Ctrl+N to open a new window.
4. Ctrl+L to focus the location bar, bugz to search for Bugzilla history entries, Down Arrow to pick one, then Enter to load it.
5. Click the location bar's dropdown arrow.

Actual results:
2 & 5. The dropdown list doesn't have a scroll bar and extends nearly to the height of the window.
4. The dropdown list has a scroll bar and extends about halfway of the window height, showing 6 entries. As I recall, it's always been this size when typing into the location bar.
(In reply to Gingerbread Man from comment #5)

> 1. Start Firefox.
> 2. Click the location bar's dropdown arrow.
> 3. Ctrl+N to open a new window.
> 4. Ctrl+L to focus the location bar, bugz to search for Bugzilla history
> entries, Down Arrow to pick one, then Enter to load it.
> 5. Click the location bar's dropdown arrow.

For me (FF42 Win7 x86):

2. The list of most visited sites has no scroll bar and shows all (12) entries.
5. The list of most visited sites has a scroll bar and shows top 6 entries.

> 4. The dropdown list has a scroll bar and extends about halfway of the
> window height, showing 6 entries. As I recall, it's always been this size
> when typing into the location bar.

The list of matching entries when typing in the location bar has always been that size (max 6 entries possibly with scroll bar); what has changed (for me) is the list of most visited sites when clicking the dropdown arrow (if I follow steps 3, 4 & 5).
(In reply to Francesco from comment #4)
> I have noticed a change since FF 42 which may be related to this bug. I'm on
> Win7 x86.
> 
> 1. Start FF and, *before using autocomplete*, click on the down arrow on the
> right of the location bar. The list of most visited sites appears, showing
> all 12 entries without scrollbar. This has always been so. It remains so
> even after using autocomplete, in all tabs, until you restart FF (or close
> the affected window).

This is a known bug, sometimes the 12 entries status persists when it shouldn't.
I can reproduce comment 4 on Win10 x86, FF42. If I follow the 5 steps in comment 5, then

2. The dropdown list has no scroll bar and shows all (12) entries.
5. The dropdown list has a scroll bar and shows top 6 entries (this is new in FF42).

Actually, step 4 can be simplified: just typing a few characters in the location bar, so that the list of matching entries is displayed, is enough.
I can reproduce the comment 4.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Even I was able to duplicate the issue mentioned in comment 4 in the latest released and nightly versions on Windows 7 x64 and Windows 10 x64. Thank you Yang for providing the regression range!
Is this still reproducible after the new location bar design and bug 1195054 (landed in today's build)?
(In reply to Guilherme Lima from comment #12)
> Is this still reproducible after the new location bar design and bug 1195054
> (landed in today's build)?

Yes, this problem persists in 48.0a1 (2016-04-08).
bug 1195054 landed for 2016-04-09
(In reply to Guilherme Lima from comment #14)
> bug 1195054 landed for 2016-04-09

Oh, looks works fine in 48.0a1 (2016-04-09).
wontfix since bug 1195054 changed the layout.
Status: NEW → RESOLVED
Closed: 8 years ago
Depends on: 1195054
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.