Closed Bug 1222472 Opened 5 years ago Closed 5 years ago

(SeaMonkey) Use ObjDirPaths for GENERATED_INCLUDES and merge with LOCAL_INCLUDES

Categories

(SeaMonkey :: Build Config, defect)

defect
Not set

Tracking

(seamonkey2.42 fixed)

RESOLVED FIXED
seamonkey2.42
Tracking Status
seamonkey2.42 --- fixed

People

(Reporter: philip.chee, Assigned: philip.chee)

References

Details

Attachments

(1 file)

See Bug 1221453 - Use Path classes for LocalInclude/GeneratedIncludes

> ==============================
> ERROR PROCESSING MOZBUILD FILE
> ==============================
> The error occurred while processing the following file:
>     c:/t1/hg/comm-central/suite/app/moz.build
> The error was triggered on line 14 of this file:
>     GENERATED_INCLUDES += ['/build']
> The underlying problem is an attempt to read a reserved UPPERCASE variable that does not exist.
> The variable read causing the error is:
>     GENERATED_INCLUDES
> Maybe you meant GENERATED_FILES or GENERATED_WEBIDL_FILES?
> Please use
>     LOCAL_INCLUDES += [ '!foo' ]
> instead of
>     GENERATED_INCLUDES += [ 'foo' ]
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8684262 - Flags: review?(bugspam.Callek)
Comment on attachment 8684262 [details] [diff] [review]
Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE

Review of attachment 8684262 [details] [diff] [review]:
-----------------------------------------------------------------

In the spirit of asking forgiveness and not permission, I'm going to say rs=me. Simple port for a bustage fix that matches bug 1222479 (which I already reviewed).
Attachment #8684262 - Flags: review?(bugspam.Callek) → review+
err I think this is a dupe of Bug 1222643 (or vice versa)
(In reply to Justin Wood (:Callek) from comment #3)
> err I think this is a dupe of Bug 1222643 (or vice versa)

oh drat.  I missed this as I didn't think it was a Mailnews Core build
config bug.

I'll back out my patch, since we're busted anyway due to
other bugs.
Product: MailNews Core → SeaMonkey
Duplicate of this bug: 1222643
Comment on attachment 8684262 [details] [diff] [review]
Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE

Pushed  to comm-central:
 https://hg.mozilla.org/comm-central/rev/3f7a1101dcd8

PS: Sorry for the spelling mistake in the commit msg.
Comment on attachment 8684262 [details] [diff] [review]
Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE

Backed out the previous patch: 
  https://hg.mozilla.org/comm-central/rev/9d4b78f58765

Pushed fixed comment patch:
 https://hg.mozilla.org/comm-central/rev/93a4f49f658c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.42
Comment on attachment 8684262 [details] [diff] [review]
Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE

Bug 1222591 seems to have caused Bug 1221453
Attachment #8684262 - Flags: review+
(In reply to Philip Chee from comment #8)
> Comment on attachment 8684262 [details] [diff] [review]
> Patch v1 Fix GENERATED_INCLUDES
> 
> Bug 1222591 seems to have caused Bug 1221453
I mean Bug 1221453 seems to have caused Bug 1222591
Status: RESOLVED → REOPENED
Depends on: 1222591
Resolution: FIXED → ---
Comment on attachment 8684262 [details] [diff] [review]
Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE

Pushed to comm-central http://hg.mozilla.org/comm-central/rev/93a4f49f658c
Attachment #8684262 - Attachment description: Patch v1 Fix GENERATED_INCLUDES → Patch v1 Fix GENERATED_INCLUDES r=clokep a=ewong CLOSED TREE
Attachment #8684262 - Flags: review+
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.