Telemetry does not report any GMPlugins in Nightly

VERIFIED FIXED in Firefox 45

Status

()

Toolkit
Telemetry
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Dexter, Assigned: Dexter)

Tracking

({regression})

Trunk
mozilla45
regression
Points:
1

Firefox Tracking Flags

(firefox44 unaffected, firefox45 verified)

Details

(Whiteboard: [measurement:client])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Bug 1218842 regressed GMPlugins, they are not showing anymore in Telemetry Environment.
(Assignee)

Updated

2 years ago
Blocks: 1218842
Points: --- → 1
Priority: -- → P1
Whiteboard: [measurement:client]
(Assignee)

Updated

2 years ago
Assignee: nobody → alessio.placitelli
(Assignee)

Comment 1

2 years ago
Created attachment 8684310 [details] [diff] [review]
bug1222503.patch

This was manually tested by enabling/disabling the OpenH264 plugin and checking the related status in about:telemetry.
Attachment #8684310 - Flags: review?(gfritzsche)
status-firefox44: --- → unaffected
Flags: qe-verify+
Keywords: regression
QA Contact: alexandra.lucinet
Comment on attachment 8684310 [details] [diff] [review]
bug1222503.patch

Review of attachment 8684310 [details] [diff] [review]:
-----------------------------------------------------------------

We really need some proper test-coverage for GMPs (i.e. with actual expected contents for active and inactive GMPs).
Lets at least file a follow-up bug about this and put this through manual testing.
Attachment #8684310 - Flags: review?(gfritzsche) → review+
Summary: Telemetry does not report any GMPlugns in Nightly → Telemetry does not report any GMPlugins in Nightly
(Assignee)

Comment 3

2 years ago
We have bug 1133310 about the test coverage. This patch went through manual testing.
Also we should add an errata entry:
https://wiki.mozilla.org/Telemetry/Errata

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/51f9f0caec60
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45

Comment 8

2 years ago
Verified fixed with latest 45.0a1 (2015-11-11), across platforms [1] - the active GMP plugins are properly submitted. 

[1] Ubuntu 14.04 64-bit, Mac OS X 10.10.5 and Windows 7 64-bit

One question here though: via about:telemetry page in Add-on Details section the information for both gmp plugins is not reliable; for example, gmp-eme-adobe is displayed on platforms where it's not available (Ubuntu, Mac OS X). This area displays the status from Add-ons Manager or it has a different meaning? Thanks in advance!
Status: RESOLVED → VERIFIED
status-firefox45: fixed → verified
Flags: qe-verify+ → needinfo?(gfritzsche)
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #8)
> One question here though: via about:telemetry page in Add-on Details section
> the information for both gmp plugins is not reliable; for example,
> gmp-eme-adobe is displayed on platforms where it's not available (Ubuntu,
> Mac OS X). This area displays the status from Add-ons Manager or it has a
> different meaning? Thanks in advance!

Hm, that sounds like something that we have to fix, we should submit similar data like what you see in the addon manager.
I assume this was a problem before already though - can you file a follow-up bug on this with more details?
Flags: needinfo?(gfritzsche) → needinfo?(alexandra.lucinet)

Comment 10

2 years ago
(In reply to Georg Fritzsche [:gfritzsche] from comment #9)
> (In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #8)
> > One question here though: via about:telemetry page in Add-on Details section
> > the information for both gmp plugins is not reliable; for example,
> > gmp-eme-adobe is displayed on platforms where it's not available (Ubuntu,
> > Mac OS X). This area displays the status from Add-ons Manager or it has a
> > different meaning? Thanks in advance!
> 
> Hm, that sounds like something that we have to fix, we should submit similar
> data like what you see in the addon manager.
> I assume this was a problem before already though - can you file a follow-up
> bug on this with more details?

Sure thing, logged bug 1225102.
Flags: needinfo?(alexandra.lucinet)
You need to log in before you can comment on or make changes to this bug.