Lockup when loading Adobe SVG plugin

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Other
--
major
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: John Ellson, Assigned: av (gone))

Tracking

({hang, regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla (Build id: 2002012623) locks up when loading Adobe SVG plugin
(plugin from: http://www.adobe.com/svg/viewer/install/old.html )

Test case: Go to http://www.graphiz.org/webdot/
then click on "SVGZ" box in top diagram.

This plugin works OK in the same environment but
with mozilla-0.9.7-1.i386.rpm from the
RedHat Rawhide collection.
~

Comment 1

16 years ago
i can confirm the testsuite at w3c org hangs moz, taking 99.9% CPU
Can't make reporters link work, but this one also shows the hang
http://www.w3.org/Graphics/SVG/Test/20011026/toc-svcmp.svg

Tseting with a current cvs, linux.
Assignee: asa → av
Severity: normal → major
Status: UNCONFIRMED → NEW
Component: Browser-General → Plug-ins
Ever confirmed: true
Keywords: hang, regression
QA Contact: doronr → shrir
(Reporter)

Comment 2

16 years ago
Sorry for typo.  URL for test case should be:
http://www.graphviz.org/webdot/

Comment 3

16 years ago
I kind of see what you mentioned. ON win, using adobe SVG 3.0, when I click on 
the image (SVGZ), I saw a License aggrement dialog. Clicked "Agree'. But the 
dialog just did not go away ( plugin loaded on top left). Right clicking inside 
the plugin and selecting "about svg" opened up a splash screen but that too does 
not disappear. Mozilla however is usable (menus,buttons,testfields). 

Comment 4

16 years ago
this seems to be fixed again. Possibly by the checkin for bug 122246 that
surfaced same day as this. Both reporters steps to repro as well as testcases at
W3C.org now load the plugin fine and renders svg. No more hang. WFM.

Comment 5

16 years ago
Will cehck today, John, can u pls check as well ? thx!
(Reporter)

Comment 6

16 years ago
Build ID: 2002020221 is working OK for me.  Thanks.

Comment 7

16 years ago
awesome.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Component: Plug-ins → Other
Product: Core → Plugins
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.