Closed Bug 1222634 Opened 4 years ago Closed 2 years ago

Box will double check when tapping under the checkbox on the duplicate contacts screen

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(blocking-b2g:2.6+, b2g-v2.5 unaffected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g 2.6+
Tracking Status
b2g-v2.5 --- unaffected
b2g-master --- affected

People

(Reporter: AdamA, Unassigned, NeedInfo)

References

()

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark])

Attachments

(1 file)

Attached file logcat
Description:
if the user is on the duplicate contacts screen and taps right under the checkbox then the the check box will encheck and check again.

Prerequisite:
Have a contact

Repro Steps:
1) Update a Aries to 20151106140230
2) Create a contact with the same info as an existing contact
3) Tap right under the checkbox on duplicate screen
4) Observe checkbox

Actual:
The box will appear to be double tapped

Expected:
it is expected that the checkbox will only change states one.

Environmental Variables:
Device: Aries 2.6 [Full Flash]
Build ID: 20151106140230
Gaia: cec4c1d3729137a24163756d15f98b0d37803966
Gecko: 512caeeb5565bb819a24ebda6a37b44fdf71b6c3
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 10/10
See attached: video clip, logcat
This issue DOES occur on Flame 2.6.

Environmental Variables:
Device: Flame 2.6 [Full Flash][512mb]
BuildID: 20151106030214
Gaia: f39a7a827c0c0f48087ff3ead94f61ae22523919
Gecko: cc48981c026c50fdf80d47b040ae1fb8fe99ad07
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
The box will appear to be double tapped
------------------------------------
This issue DOES NOT occur on Flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash][512mb]
BuildID: 20151105004500
Gaia: 47da49f8206788d70d834c3a63d9245d50c89103
Gecko: 5c9fd135d4309239794126f1942d6e7aa8b3579c
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Result:
the box will only check once.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This could lead to end user frustration so nominating this 2.6?
blocking-b2g: --- → 2.6?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+],[MGSEI-Triage+]
b2g-inbound Regression Window:

Last Working Environmental Variables:
Device: Flame KK master
Build ID               20150728075544
Gaia Revision          ba33139c251108308cf882c152d9a7fff001bb83
Gaia Date              2015-07-28 13:36:25
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/37b209a43f65
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150727.183206
Firmware Date          Mon Jul 27 18:32:18 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK master
Build ID               20150728092745
Gaia Revision          862f0895f3f5a97200601542d99a152a46385a0b
Gaia Date              2015-07-28 15:30:25
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/abf601a06c59
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150727.183206
Firmware Date          Mon Jul 27 18:32:18 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES repro
Gaia Revision          862f0895f3f5a97200601542d99a152a46385a0b
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/37b209a43f65

First Broken Gecko & Last Working Gaia – issue DOES NOT repro
Gaia Revision          ba33139c251108308cf882c152d9a7fff001bb83
Gecko Revision         https://hg.mozilla.org/integration/b2g-inbound/rev/abf601a06c59

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/ba33139c251108308cf882c152d9a7fff001bb83...862f0895f3f5a97200601542d99a152a46385a0b

Hi Jorge,
  
  This bug is probably caused by Bug 1182509, could you please help to check?  Thank you.
Flags: needinfo?(jpruden92)
Isabel is this not a duplicate of bug 1202359 ?

Does it have to do with the fact that is more than one check box?
Flags: needinfo?(irios.mozilla)
Francisco, yes is looks like the same bug.

You are right about having more than one check box, only with one contact to merge I was unable to reproduce, you need at least two.

Since the other bug is already Verified, lets keep this open till it is fixed for master too, what do you think?

Thanks!
Flags: needinfo?(irios.mozilla) → needinfo?(francisco)
Perfect, thanks for the information Isabel, it's pretty useful.
Flags: needinfo?(francisco)
blocking-b2g: 2.6? → 2.6+
Priority: -- → P1
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.