[Aries] Red debug box is briefly visible at the very beginning of the FTU

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::First Time Experience
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Marty, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.5 unaffected, b2g-master affected)

Details

(Whiteboard: [2.6-Daily-Testing][Spark], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8684478 [details]
logcat_red-square-flash.txt

Description:
When the device first loads up the FTU after a Fresh Flash, or a System Reset, a red debug square with the number '1' in it is briefly visible in the lower right corner of the screen.  This is visible just before the language list is displayed.

Repro Steps:
1) Update a Aries to 20151106140230
2) As the FTU starts up, look at the lower right corner of the screen.

Actual:
Red debug square with the number '1' is visible in the bottom right corner for approximately 1 second.

Expected:
Red debug square does not appear at the beginning of the FTU

Environmental Variables:
Device: Aries 2.6
Build ID: 20151106140230
Gaia: cec4c1d3729137a24163756d15f98b0d37803966
Gecko: 512caeeb5565bb819a24ebda6a37b44fdf71b6c3
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 5/5
See attached: Video (URL), Logcat
(Reporter)

Comment 1

2 years ago
This issue does NOT occur on the Aries RC4 2.5 build or the latest Flame 2.6 build.
Red debug square does not appear at the beginning of the FTU

Environmental Variables:
Device: Aries 2.5
BuildID: 20150619225606
Gaia: 4c06ed88ddccaba8dc941e5006bd2a9e57306f07
Gecko: 7c1a6b1151a1539186b950a144387e2d7f378d1b
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 41.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Environmental Variables:
Device: Flame 2.6
BuildID: 20151106030214
Gaia: f39a7a827c0c0f48087ff3ead94f61ae22523919
Gecko: cc48981c026c50fdf80d47b040ae1fb8fe99ad07
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 (2.6) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
This issue is no longer occurring on the latest Aries 2.6 build

No red debug square appears in the FTU.

Device: Aries 2.6
BuildID: 20151109152230
Gaia: 23cab7ea0fcecab7689d340baf604e024e88f9a3
Gecko: e1ef2be156de1dad31bb4189a51b178b12b23340
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Please reopen this issue if encountered again.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.