Closed Bug 1222702 Opened 7 years ago Closed 7 years ago

Homescreen allows horizontal and vertical scroll/pan at the same time, which looks strange

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

All
Other
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1217350

People

(Reporter: emorley, Unassigned)

Details

(Keywords: foxfood)

>> Feature Request Summary:
Homescreen allows horizontal and vertical scroll/pan at the same time, which looks strange

>> Description of feature, or problem to be solved
Using the Z3C foxfooding device with the latest FOTA/OTA installed (build number: eng.naoki.20151007.074137, build identifier 20151023101519).

STR:
1) At the homescreen, press and drag the apps list to the left, as though you were switching to "pin the web"
2) Without letting go, also scroll down
3) Repeat, but starting with the vertical scroll before the horizontal scroll.

Expected:
When a horizontal or vertical scroll has been started, don't allow scrolling in the other axis until the finger has been released.

Actual:
A strange hybrid scroll that shows part scrolling apps list and part "pin the web" view.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1217350
You need to log in before you can comment on or make changes to this bug.