Create editorTasksOverlay to allow optional inclusion of Composer button on the component bar

VERIFIED FIXED in mozilla1.0

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: cmanske, Assigned: cmanske)

Tracking

Trunk
mozilla1.0
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(10 obsolete attachments)

(Assignee)

Description

17 years ago
Spin-off request from bug 89975:
> Moved all editor-related code out of XPFE and into editorApplicationOverlay.js,
> which is included via editorNavigatorOverlay.xul by the browser.

But not by other apps. This means that the editor button in the component bar is
broken unless the app happens to overlay editorNavigatorOverlay.xul or
editorMailOverlay.xul, i.e. only for browser and mail, but not e.g. ChatZilla.

Please either move NewEditorWindow() back to tasksOverlay.js, or (better) create
editorTasksOverlay.xul and editorTasksOverlay.js to resolve this, thus making it
easier to remove Editor.

Comment 1

17 years ago
Created attachment 67742 [details]
Proposed editorTasksOverlay.xul

Comment 2

17 years ago
Created attachment 67745 [details] [diff] [review]
Changes to tasksOverlay.*
(Assignee)

Comment 3

17 years ago
I'll test this soon.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9

Comment 4

17 years ago
Created attachment 67902 [details]
Wrong editorTasksOverlay.xul last time :-)
Attachment #67742 - Attachment is obsolete: true

Comment 5

17 years ago
Created attachment 67903 [details] [diff] [review]
Tweak mailTasksOverlay.xul

This patch ensures that Composer appears in the correct place in the tasks menu
and component bar in case mailTasksOverlay.xul loads before
editorTasksOverlay.xul as I'm not sure if the load order can be guaranteed.
(Assignee)

Comment 6

17 years ago
This is Neil's work.
Keywords: nsbeta1+

Comment 7

17 years ago
Created attachment 68520 [details]
editorTasksOverlay.xul bitrotted
Attachment #67902 - Attachment is obsolete: true

Comment 8

17 years ago
Created attachment 68521 [details] [diff] [review]
tasksOverlay.* bitrotted
Attachment #67745 - Attachment is obsolete: true

Comment 9

17 years ago
Created attachment 68522 [details] [diff] [review]
mailTasksOverlay.xul bitrotted
Attachment #67903 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Whiteboard: NEIL
(Assignee)

Comment 10

17 years ago
*** Bug 124366 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

17 years ago
*** Bug 126281 has been marked as a duplicate of this bug. ***

Comment 12

17 years ago
Created attachment 70531 [details] [diff] [review]
Changes to contents.rdf

Sorry, I forgot to do these earlier.
(Assignee)

Comment 13

17 years ago
Problems I see with this:
1. In Browser and Mail windows, the Composer task icon is in the 1st position
2. You need to alter addressbook.xul and messengercompose.xul just as you did
for others.
3. When an existing Composer window is found, the focus doesn't propagate to
the editing content window -- must click in there to edit. (This probably isn't
your fault!)
4. Add editorTasksOverlay.xul to editor\jar.mn
5. The method toEditor() can simply be:
    function toEditor()
    {
      if (!CycleWindow("composer:html"))
        // Defined in editorApplicationOverlay.js
        NewEditorWindow();
    }
Anyone including editorTasksOverlay.xul should also have access to 
editorApplication.js. On this topic, maybe we should just have 
editorTasksOverlay.xul and .js and elliminate editorApplicationOveralay.js?
The latter isn't complete anyway: There are still "menu_newEditor" items in
other module XUL that should be added only via a Composer overlay.
And the New Blank page commands are still broken in history (bug 126281),
Addressbook, and JS Console windows. I think we should try to solve all of these
with one editor overlay set.

Comment 14

17 years ago
Charles Manske wrote:

> Problems I see with this:
> 1. In Browser and Mail windows, the Composer task icon is in the 1st position

I don't see this. I can't even see how this would happen.

> 2. You need to alter addressbook.xul and messengercompose.xul just as you did
> for others.

I don't understand this comment. They use tasksOverlay, that's the point.

> 3. When an existing Composer window is found, the focus doesn't propagate to
> the editing content window -- must click in there to edit. (This probably
> isn't your fault!)

I don't know what happened before, sorry.

> 4. Add editorTasksOverlay.xul to editor\jar.mn

Is it just this file that's affected?

5. <snip>

I disagree. The point is that editorApplicationOverlay is only used to overlay
the browser and messenger, it has no relevance to the rest of Mozilla.
(Assignee)

Comment 15

17 years ago
changing milestone
Target Milestone: mozilla0.9.9 → mozilla1.0

Comment 16

17 years ago
Created attachment 70919 [details] [diff] [review]
Changes to editorApplicationOverlay.js

Really sorry for missing this one off, must have confused you somewhat!
(Assignee)

Comment 17

17 years ago
*** Bug 127036 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

17 years ago
*** Bug 127523 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

17 years ago
Comment on attachment 68520 [details]
editorTasksOverlay.xul bitrotted

r=cmanske
Attachment #68520 - Flags: review+
(Assignee)

Comment 20

17 years ago
Comment on attachment 68521 [details] [diff] [review]
tasksOverlay.* bitrotted

r=cmanske
Attachment #68521 - Flags: review+
(Assignee)

Comment 21

17 years ago
Comment on attachment 68522 [details] [diff] [review]
mailTasksOverlay.xul bitrotted

r=cmanske
Attachment #68522 - Flags: review+
(Assignee)

Comment 22

17 years ago
Comment on attachment 70531 [details] [diff] [review]
Changes to contents.rdf

r=cmanske
Attachment #70531 - Flags: review+
(Assignee)

Comment 23

17 years ago
Comment on attachment 70919 [details] [diff] [review]
Changes to editorApplicationOverlay.js

r=cmanske
Attachment #70919 - Flags: review+
(Assignee)

Updated

17 years ago
Keywords: patch, review
Whiteboard: NEIL → NEIL, FIX IN HAND, need sr=

Comment 24

17 years ago
Comment on attachment 68520 [details]
editorTasksOverlay.xul bitrotted

sr=hewitt
Attachment #68520 - Flags: superreview+

Comment 25

17 years ago
Comment on attachment 68521 [details] [diff] [review]
tasksOverlay.* bitrotted

sr=hewitt
Attachment #68521 - Flags: superreview+

Updated

17 years ago
Attachment #68522 - Flags: superreview+

Comment 26

17 years ago
Comment on attachment 68522 [details] [diff] [review]
mailTasksOverlay.xul bitrotted

sr=hewitt

Comment 27

17 years ago
Comment on attachment 70531 [details] [diff] [review]
Changes to contents.rdf

sr=hewitt
Attachment #70531 - Flags: superreview+

Comment 28

17 years ago
Comment on attachment 70919 [details] [diff] [review]
Changes to editorApplicationOverlay.js

sr=hewitt
Attachment #70919 - Flags: superreview+

Comment 29

17 years ago
Comment on attachment 68520 [details]
editorTasksOverlay.xul bitrotted

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #68520 - Flags: approval+

Comment 30

17 years ago
Comment on attachment 68521 [details] [diff] [review]
tasksOverlay.* bitrotted

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #68521 - Flags: approval+

Comment 31

17 years ago
Comment on attachment 68522 [details] [diff] [review]
mailTasksOverlay.xul bitrotted

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #68522 - Flags: approval+

Comment 32

17 years ago
Comment on attachment 70531 [details] [diff] [review]
Changes to contents.rdf

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #70531 - Flags: approval+

Comment 33

17 years ago
Comment on attachment 70919 [details] [diff] [review]
Changes to editorApplicationOverlay.js

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #70919 - Flags: approval+
(Assignee)

Updated

17 years ago
Whiteboard: NEIL, FIX IN HAND, need sr= → NEIL, FIX IN HAND, approved
(Assignee)

Comment 34

17 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: NEIL, FIX IN HAND, approved

Comment 35

17 years ago
Created attachment 75958 [details] [diff] [review]
Preventative measure

I have been able to break my build of Mozilla by manually editing some internal
configuration files, and I am worried that normal use of Mozilla may reproduce
my edits, which would break the tasks menu. However this patch prevents that.
(Assignee)

Updated

17 years ago
Attachment #68520 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #68521 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #68522 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #70531 - Attachment is obsolete: true
(Assignee)

Updated

17 years ago
Attachment #70919 - Attachment is obsolete: true

Comment 36

17 years ago
Charley, please verify this bug...thanks
(Assignee)

Comment 37

17 years ago
Reopened to work on issue Neil found with overlay load order.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 38

17 years ago
verification instructions per cmanske = verify New Blank Page works from all
modules.

Comment 39

17 years ago
also test that the icons for each moduel on the taskbar appear in the correct
order.
(Assignee)

Comment 40

17 years ago
Comment on attachment 75958 [details] [diff] [review]
Preventative measure

r=cmanske
This controls order of overlay loading so editorTasksOverlay is always loaded
before mailTaskOverlay
Attachment #75958 - Flags: review+
(Assignee)

Updated

17 years ago
Blocks: 133167
(Assignee)

Comment 41

17 years ago
I'm going to mark this fixed. The new patch addresses problem reported 
separately in bug 133167 and is moved there.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Updated

17 years ago
Attachment #75958 - Attachment is obsolete: true

Comment 42

17 years ago
verified in 3/26 build.

REOPEN if anyone disagrees.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.