Validation says 2 errors, full validation report shows none

RESOLVED WORKSFORME

Status

addons.mozilla.org Graveyard
Add-on Validation
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Emiliano Heyns, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8684695 [details]
zotero-better-bibtex-1.6.5.xpi

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/46.0.2490.80 Safari/537.36

Steps to reproduce:

Uploaded my extension to https://addons.mozilla.org/en-US/developers/addon/validate


Actual results:

Validation result was "Your add-on was validated with no errors and 2 warnings.", but when I click the link for the full validation report it shows no warnings.


Expected results:

It should have showed the warnings.
There's a checkbox with the label "Hide messages not required for automated signing". If you uncheck it, the messages should appear. It's a new feature, so that also confused me for a minute.
(Reporter)

Comment 2

2 years ago
It is perhaps available on the submission page, but I can't find it anywhere at https://addons.mozilla.org/en-US/developers/addon/validate . I occasionally use that URL to "pre-flight" my extension without using up a version number.
No, I tried with /validate. I saw the checkbox in the full results page.
(Reporter)

Comment 4

2 years ago
Ah, *there*. Right, got it. Thanks, I want zero warnings as I don't want to be caught later when warnings turn might be reclassified as errors.
Let's call this WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.