bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[devtools][computedview] There are some invalid browser styles when using copy and paste

RESOLVED DUPLICATE of bug 1222737

Status

DevTools
Inspector
RESOLVED DUPLICATE of bug 1222737
3 years ago
a month ago

People

(Reporter: magicp, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(firefox44 affected, firefox45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8684722 [details]
devtools-computed-browser-styles.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20151108030417

Steps to reproduce:

1. Run latest Nightly
2. Open "about:home"
3. Open DevTools > Inspector > Computed
4. Enable Browser Styles checkbox
5. Click Select All and Copy in context menu
6. Open Stylesheet editor
7. Click New button
8. Paste browser styles in new stylesheet


Actual results:

The following browser styles concatenate style name, value and next line when using copy and paste.

caption-side:
object-fit:
text-overflow:




Expected results:

Should not concatenate style name, value and next line.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
status-firefox44: --- → affected
status-firefox45: --- → affected
Component: Untriaged → Developer Tools: Inspector
OS: Unspecified → All
Hardware: Unspecified → All
Version: 42 Branch → Trunk
The STR is a little different than bug 1222737 but the root cause seems to be the same. Duplicating this bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1222737

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.