problem with drop-down box (<SELECT>) in forms with slightly weird html

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: bko, Assigned: alexsavulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
This problem occurs w/ slightly unbalanced HTML (see attached) on 0.9.7.  It
works fine in Netscape 4.

With the unbalanced <font> in this example, selecting ANY entry in the dropdown
selects the first entry (AL), no matter which i chose from the list.

Submitting the form shows that AL is indeed the selection.

This bug appears when selecting a user rating on half.com and when selecting the
shipping state on stores.yahoo.com .

This doesn't happen w/ the <font> balanced or if you change the spacing of
<form></form>, so I'm guessing that the engine tries to guess where to balance
the </font> and guesses wrong, but I have no idea why that would cause the bug.
(Reporter)

Comment 1

17 years ago
oops -- looks like the problem is w/ 0.9.6.  however, i seem to recall that my
0.9.7 at home has the same problem.
(Reporter)

Comment 2

17 years ago
Created attachment 66819 [details]
test case which exhibits the bug.

simplest test case i can find which exhibits the bug.  I think that this may be
two bugs -- the engine guesses where to put the </font> incorrectly, which
triggers the real bug (the can't select bug).
worksforme with current build.  A lot of form control stuff got rewritten
post-0.9.6 and some more post-0.9.7 so please retest with a recent build,
(Reporter)

Comment 4

17 years ago
works for me as well on the latest nightly.  sorry about that.
Not a problem.  Marking worksforme, but please reopen if this pops up again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 6

17 years ago
verifying on build 2002-02-25-09-trunk linux red Hat
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.