large ftp directories are painfully slow

RESOLVED DUPLICATE of bug 85381

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 85381
16 years ago
13 years ago

People

(Reporter: Cryo, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
If you use an ftp client and do a dir on the URL above, you'll see it whip past
quickly.  However, mozilla will take upwards of 10 minutes to display the directory.

(opinion)This sounds like the same type of thing that Mozilla has with listing a
large number of bugs in bugzilla(/opinion).

Comment 1

16 years ago
WFM 2002012806-0.9.8/WinNT4 - I'm on a modem, but it seems to be listing
the directory contents in the window just as fast as it gets the data.
Checked against WS_FTP, times were about the same.

Mind you, it's taking 100% of CPU to do it.

(Dear me, has HP ever heard of subdirectories?)

Comment 2

16 years ago
Reporter: Please always include build ID in bug-reports.
Dup of bug 85381?
(Reporter)

Comment 3

16 years ago
Version 2002012803 Win32
Version 2002012703 Mac OS 9.2.2
Version 20020125xx Mac OS X

FWIW, I concur that it's a dupe of bug 85381

Even on the 600MHz P3 Win32, the CPU is pegged at 100% for at least 2 mins.
Using ftp the directory finishes in about 8 seconds.

Slower CPU's feel exponentially more horrible (the OS 9.2.2 is a G3 233, and
takes about 10 minutes).  The G4 450 running OS X takes about 5.

(Assignee)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 85381 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.