Don't accidentally initialize BrowserDB during application:willFinishLaunchingWithOptions

RESOLVED FIXED

Status

()

Firefox for iOS
Data Storage
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rnewman, Assigned: rnewman)

Tracking

unspecified
All
iOS

Firefox Tracking Flags

(fxios1.2+)

Details

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Assignee)

Description

3 years ago
See Bug 1223017.

We grab profile.history in order to invalidate the top sites cache… but that involves doing all of the table init for BrowserTable and perhaps checkpointing the WAL.

My proposed fix is to have SQLiteHistory flag itself during init.
(Assignee)

Comment 1

3 years ago
Created attachment 8685017 [details] [review]
Pull req.
Attachment #8685017 - Flags: review?(sleroux)
Attachment #8685017 - Flags: review?(sleroux) → review+
(Assignee)

Comment 2

3 years ago
c2b2c2c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
tracking-fxios: --- → 1.2+
Resolution: --- → FIXED
(Assignee)

Comment 3

3 years ago
bnicholson spotted some really weird behavior caused by this commit. Inlining the method call fixed it:

02491fc
You need to log in before you can comment on or make changes to this bug.