No win64 updates since the 2015-11-05 Nightly

RESOLVED DUPLICATE of bug 1115490

Status

()

Toolkit
Application Update
--
blocker
RESOLVED DUPLICATE of bug 1115490
2 years ago
2 years ago

People

(Reporter: ehoogeveen, Unassigned)

Tracking

Trunk
x86_64
Windows
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

(Reporter)

Description

2 years ago
Since the 2015-11-05 win64 Nightly, checking for updates yields nothing; checking simply says "Nightly is up to date".

Going back to an older Nightly (pre 2015-11-05) and checking for updates, it updates *to* the 2015-11-05 Nightly.

32-bit Nightlies seem to be unaffected - updating from the 2015-11-04 32-bit Nightly yields the 2015-11-08 Nightly. It appears 64-bit Nightly updates past 2015-11-05 are simply missing.

The same thing happens on a fresh profile, and other users are reporting the same problem: http://forums.mozillazine.org/viewtopic.php?f=23&t=2972339

As a result of this bug, many Nightly users are likely not testing the latest Nightlies.

STR #1
  Download and install an older win64 Nightly (2015-11-05 or newer) and check for updates
Expected
  Should begin to download an update
Actual
  Says Nightly is up to date

STR #2
  Download and install an older win64 Nightly (2015-11-04 or older) and check for updates
Expected
  Should update to the latest Nightly
Actual
  Updates to the 2015-11-05 Nightly

Comment 1

2 years ago
Browser Console log with app.update.log=true

AUS:SVC UpdateManager:_loadXMLFileIntoArray: XML file does not exist
AUS:SVC Creating UpdateService
AUS:SVC Checker: checkForUpdates, force: true
AUS:SVC Checker:getUpdateURL - update URL: https://aus5.mozilla.org/update/3/Firefox/45.0a1/20151105030433/WINNT_x86_64-msvc-x64/en-US/nightly/Windows_NT%206.1.1.0%20(x64)/default/default/update.xml?force=1
AUS:SVC Checker:checkForUpdates - sending request to: https://aus5.mozilla.org/update/3/Firefox/45.0a1/20151105030433/WINNT_x86_64-msvc-x64/en-US/nightly/Windows_NT%206.1.1.0%20(x64)/default/default/update.xml?force=1
AUS:SVC Checker:onLoad - request completed downloading document
AUS:SVC Checker:onLoad - number of updates available: 0
UTM:SVC TimerManager:notify - notified @mozilla.org/browser/search-service;1
AUS:SVC UpdateService:removeDownloadListener - no downloader!

Updated

2 years ago
Blocks: 558448

Updated

2 years ago
Summary: No win64 updates since the 2011-11-05 Nightly → No win64 updates since the 2015-11-05 Nightly
I think this is just fallout from bug 1115490.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1115490
(Reporter)

Comment 3

2 years ago
It might be; are the builds that the update server looks for different from the ones at http://archive.mozilla.org/pub/firefox/nightly/latest-mozilla-central/? I ask because those are still being updated - though the update server always seems to be at least several hours behind (e.g. when I wrote this bug, the win32 Nightly would update to the 2015-11-08 build, while archive.mozilla.org already had the 2015-11-09 build).
Resolution: DUPLICATE → FIXED
(Reporter)

Comment 4

2 years ago
Sorry, I didn't mean to undo the duplicate.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1115490
I believe so. Depends on when the jobs time out, according the last comment in that bug.

Comment 6

2 years ago
¬°Hola!

I'm not sure what fixed it, but I just got an update to Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0 ID:20151110030205 CSet: cc473fe5dc512c450634506f68cbacfb40a06a23

¬°Gracias!
Alex
(Reporter)

Comment 7

2 years ago
As I understand it, this is an intermittent problem: sometimes builds do succeed, but most of the time (at least the Nightly builds) they fail. The 2015-11-10 build happened to succeed, but it looks like the 2015-11-11 build did not.

There's a patch up in bug 1115490 to increase the timeout on the builds so they will hopefully succeed all the time again.
You need to log in before you can comment on or make changes to this bug.