homepage_url should be displayed in about:addons

VERIFIED FIXED

Status

VERIFIED FIXED
3 years ago
4 months ago

People

(Reporter: anaran, Assigned: andy+bugzilla, Mentored)

Tracking

({dev-doc-needed})

unspecified
dev-doc-needed
Bug Flags:
blocking-webextensions -

Firefox Tracking Flags

(firefox48 verified)

Details

(Whiteboard: [good-first-bug] [lang=js]triaged)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151018052213

Steps to reproduce:

Add homepage_url field to local git clone of
https://github.com/mdn/webextensions-examples/tree/master/beastify

Build with
/var/tmp/webextensions-examples/beastify$ zip -r ../beastify.xpi *
and install that
beastify.xpi



Actual results:

The homepage_url is nowhere to be seen in about:addons


Expected results:

Just like the jetpack add-on homepage field from package.json is displayed in about:addons, so should homepage_url.

See https://developer.chrome.com/extensions/manifest/homepage_url
(Reporter)

Updated

3 years ago
Flags: blocking-webextensions?(amckay)
(Assignee)

Comment 1

3 years ago
Oh I didn't know that existed. We should do this, but I don't think its a blocking bug.
Flags: blocking-webextensions?(amckay) → blocking-webextensions-
It looks like we'll need to change the code at https://dxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#918 to use the homepage_url from the manifest, with a call to getProp("homepage_url")…

Adrian, would you like to try fixing this one?
Mentor: bwinton
Flags: needinfo?(adrian.aichner)
Whiteboard: [good-first-bug] [lang=js]
(Reporter)

Comment 3

3 years ago
Looking at
https://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/extensions/internal/XPIProvider.jsm#918
I would suggest to handle the other null fields as well.

I am currently not set up to build Firefox since I moved from Windows XP to Ubuntu.

It can hardly be the editing of the file you want help with.

What would be the major chunk of work involved?
Flags: needinfo?(adrian.aichner)
I don't think we need to handle most of the other null fields, at least not in this bug, although if you felt like it, I suspect that fix would be accepted.  And yes, it is the editing of the file (and making sure the tests run and the code passes review) I'ld like help with.  It's not that I couldn't make the change, it's more that I'm trying to do a million other things, and if someone can do this instead of me, that frees me up to work on other stuff.  :)

Also, since you reported the bug, I think you probably have a better idea of what other fields should be added than the rest of us…
(Reporter)

Updated

3 years ago
Assignee: nobody → adrian.aichner
(Reporter)

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 5

3 years ago
Here's my change, tested in my debugger in 45.0a1 (2015-11-27)

https://github.com/anaran/gecko-dev/commit/87f7d53e982460d5d752a49217f9d666a15492a2

I did this one online on github, so no patch (yet).
(Reporter)

Comment 6

3 years ago
Created attachment 8693045 [details]
github raw patch
(Reporter)

Comment 7

3 years ago
Created attachment 8693046 [details] [diff] [review]
github raw patch
(Reporter)

Updated

3 years ago
Attachment #8693045 - Attachment is obsolete: true
Attachment #8693045 - Attachment is patch: false
(Reporter)

Updated

3 years ago
Attachment #8693046 - Flags: review?(bwinton)
(Reporter)

Comment 8

3 years ago
I was able to see the homepage URL show up under about:addons.

Clicking on it opens a new tab for that URL.

I used a build[1] in directory
https://github.com/anaran/webextensions-examples/tree/Issue_16/notify-link-clicks
to test a manifest with a homepage_url

and
https://github.com/anaran/webextensions-examples/tree/communicate/communicate
to test a manifest without a homepage_url

Both cases worked in the debugger.

[1] zip -r ../$(basename $(pwd)).xpi *
Comment on attachment 8693046 [details] [diff] [review]
github raw patch

I think this will be okay, but I'm redirecting to Mossop for the actual review.
I also suspect we'll want to add some tests, but I'm not sure where to put those.
Attachment #8693046 - Flags: review?(bwinton) → review?(dtownsend)
Comment on attachment 8693046 [details] [diff] [review]
github raw patch

Review of attachment 8693046 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I'd sure love to see this added to the tests though.
Attachment #8693046 - Flags: review?(dtownsend) → review+
(Assignee)

Comment 11

3 years ago
Any chance to work on tests :anaran, so we can merge?
Flags: needinfo?(adrian.aichner)
(Assignee)

Updated

3 years ago
Whiteboard: [good-first-bug] [lang=js] → [good-first-bug] [lang=js]triaged
(Reporter)

Comment 12

3 years ago
I don't see myself working on the tests in the near future.

Being a mozilla contributor has become more and more of a drag after investing in a number of mozilla-dead-ends:

cfx, jpm, jetpack (AKA add-on SDK), Firefox OS, DOM:Apps, Thunderbird.

I'll go mozilla-agnostic for a while and migrate to technologies which will still work should mozilla drop firefox or whatever (service worker, chrome extensions, etc.).
Flags: needinfo?(adrian.aichner)
(Reporter)

Updated

3 years ago
Assignee: adrian.aichner → nobody
Status: ASSIGNED → NEW
(Assignee)

Updated

3 years ago
Assignee: nobody → amckay
(Assignee)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
I was able to reproduce the initial issue on Firefox 44.0a1 (2015-10-21) under Windows 10 64-bit.

Verified fixed on Firefox 48.0a1 (2016-03-27) under Windows 10 64-bit, Ubuntu 12.04 32-bit and Mac OS X 10.11. The homepage url is successfully displayed in about:addons.
Status: RESOLVED → VERIFIED
status-firefox48: --- → verified
(Assignee)

Updated

3 years ago
Keywords: dev-doc-needed

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.