Make searchbox style consistent across tools

RESOLVED FIXED in Firefox 68

Status

defect
P5
normal
RESOLVED FIXED
4 years ago
12 days ago

People

(Reporter: ntim, Assigned: ntim)

Tracking

unspecified
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
No description provided.

Updated

Last year
Product: Firefox → DevTools
Assignee

Updated

4 months ago
Component: General → CSS and Themes

Hi Victoria! Is the searchbox style in the Photon guidelines the one we need to use everywhere? https://firefox-dev.tools/photon/components/input-fields.html Are there some panels that should have a different style for their searchboxes? Thanks!

Flags: needinfo?(victoria)
Priority: -- → P5

Hi Belén! For in-content pages like about:debugging, that page has the correct styling. Search boxes inside DevTools panels should follow the more minimal style currently in Netmonitor/Console. More info: https://mozilla.invisionapp.com/share/2XEEY0RYA#/screens/263398480

Flags: needinfo?(victoria)

Comment 3

3 months ago

Hi everyone,

I was wondering if I could try to solve this if this is available.

For this issue, tools mentioned are the tabs in the Devtools?
I can check all occurrences of the searchbox and log here so you can check if they are all that need to be changed.

Thanks!

Hi Mellina, sorry again for the late reply!

Currently, the Inspector part of this is being worked on in this bug. I think Gabe mentioned he could could apply this to other areas (Style Editor, Network headers?) while he's at it. If that's the case, he might want to take over this bug.

Flags: needinfo?(gl)
Assignee

Updated

2 months ago
Assignee: nobody → ntim.bugs

Comment 6

Last month
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c8a2cbf18f3c
Refactor searchbox style to be consistent across tools. r=fvsch,gl,Honza,nchevobbe

Comment 8

Last month
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/784c0c4b688b
Refactor searchbox style to be consistent across tools. r=fvsch,gl,Honza,nchevobbe
Assignee

Updated

Last month
Flags: needinfo?(ntim.bugs)

Comment 9

Last month
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4440662cd017
Followup: fix browser_inspector_search-01/06.js failures on a CLOSED TREE. r=me

Comment 10

Last month
bugherder
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Clearing needinfo since this is fixed.

Flags: needinfo?(gl)
Assignee

Updated

12 days ago
Regressions: 1551870
You need to log in before you can comment on or make changes to this bug.