Helvetica Neue renders as black outline

RESOLVED DUPLICATE of bug 1221263

Status

()

RESOLVED DUPLICATE of bug 1221263
3 years ago
3 years ago

People

(Reporter: greg, Unassigned)

Tracking

42 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8685545 [details]
Screenshot of Box.com, Helvetica Neue Bold is outlined

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151029151421

Steps to reproduce:

See screenshot


Actual results:

See screenshot


Expected results:

See screenshot

Updated

3 years ago
Component: Untriaged → Graphics: Text
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1185812

Comment 2

3 years ago
Bug 1185812 states:   "status-firefox42: fixed"

Isn't that true?
Ah, sorry, I got platform and version details confused.

So in fact this is not a duplicate of bug 1185812, because it's on OS X; that was reported for Linux. Instead, I think this was actually a regression triggered by the patch in bug 1185812, and is essentially the same issue as bug 1221263 (just manifested with the Helvetica Neue family rather than Hoefler Text as reported there).

That is supposed to be fixed as part of bug 1201318, currently on FF44 and awaiting uplift to 43. If for some reason that uplift runs into problems, the minimal patch in bug 1221263 should also be sufficient to fix this; updating the duplicate reference here accordingly.
Duplicate of bug: 1221263
You need to log in before you can comment on or make changes to this bug.