Should copy files, not aliases, into new profile directories

VERIFIED FIXED in M12

Status

Core Graveyard
Profile: BackEnd
P2
normal
VERIFIED FIXED
19 years ago
2 years ago

People

(Reporter: Simon Fraser, Assigned: gayatrib)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If I create a new profile on Mac, the profile folder is created in the wrong
place. Instead of being in <system disk>:Documents:Mozilla, it was created
inside a folder with no name in the same directory as apprunner. This is bad.

Also, when creating a new profile, the folder ends up with aliases of the files
in the profile/default directory, which is wrong. The files should be copied,
and not aliased (since files like bookmarks.html get modified at runtime, and
we should never be modifying files that are in the tree (via alias)).

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 1

19 years ago
gfx text widget problem.

*** This bug has been marked as a duplicate of 12186 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

19 years ago
Status: VERIFIED → REOPENED
Summary: New profile directories created in the wrong place → Should copy files, not aliases, into new profile directories
(Reporter)

Updated

19 years ago
Resolution: DUPLICATE → ---
(Reporter)

Comment 2

19 years ago
Please note the other issues noted here:

Also, when creating a new profile, the folder ends up with aliases of the files
in the profile/default directory, which is wrong. The files should be copied,
and not aliased (since files like bookmarks.html get modified at runtime, and
we should never be modifying files that are in the tree (via alias)).
(Reporter)

Comment 3

19 years ago
Please note the other issues noted here:



Also, when creating a new profile, the folder ends up with aliases of the files

in the profile/default directory, which is wrong. The files should be copied,

and not aliased (since files like bookmarks.html get modified at runtime, and

we should never be modifying files that are in the tree (via alias)).

Updated

19 years ago
Assignee: selmer → gayatrib
Status: REOPENED → NEW

Comment 4

19 years ago
Gayatri, Looks like the recursive copy routine on the mac isn't doing the right
thing.  Can you look into this one?  Thanks,  Steve

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M11

Updated

19 years ago
Blocks: 12696
(Assignee)

Updated

18 years ago
Assignee: gayatrib → racham
Target Milestone: M11 → M12
(Assignee)

Updated

18 years ago
Assignee: racham → gayatrib
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

18 years ago
Thanks to Simon's help, this has been fixed.

Comment 6

18 years ago
build 1999100713
Status: RESOLVED → VERIFIED

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 7

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.