Job rendering code in UI could be simplified a bit

RESOLVED FIXED

Status

Tree Management
Treeherder
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: wlach, Assigned: wlach)

Tracking

Details

Attachments

(1 attachment)

While trying to diagnose the issues behind a treeherder memory leak (see bug 1223445), I realized that some of the code to populate the jobs table could be simplified a bit. There are other fixes we should consider (not using jQuery selectors to construct html content for one, which I suspect is the cause of the memory leak), but I figured at least clarifying the existing code would be a start.
Created attachment 8685552 [details] [review]
PR

Pretty straightforward refactoring/simplification. Works good locally.
Attachment #8685552 - Flags: review?(cdawson)
Comment on attachment 8685552 [details] [review]
PR

I did some testing of this myself.  It seems to work well.
Attachment #8685552 - Flags: review?(cdawson) → review+
Checked in a slightly updated/rebased patch (camd changed some related code in bug 1197258).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Summary: Job code could be simplified a bit → Job rendering code in UI could be simplified a bit
You need to log in before you can comment on or make changes to this bug.