Closed Bug 1223556 Opened 4 years ago Closed 4 years ago

Marketplace app does not work properly when selecting More option links.

Categories

(Marketplace Graveyard :: General, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
2015-11-24

People

(Reporter: vbelonenko, Assigned: spasovski)

References

()

Details

(Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(1 file)

Description:
When selecting More option inside the Marketplace app and selecting different links the app does not take you directly to that link.

Repro Steps:
1) Update a Aries to 20151110122027
2) Launch Marketplace app
3) Select More option and select Sites or Adds
4) Select More option again and select Adds
5) Select More option again and select Sites
6) Observe that link does not take user directly to the same page.

Actual:
Selecting Marketplace app and selecting More option the links do not launch correct pages.

Expected:
When Selecting More option should take you directly to correct pages.

Environmental Variables:
Device: Aries Master 2.6 kk full flash
Build ID: 20151110122027
Gaia: c0482775b1526add626b170dd53a72d10bcaf07c
Gecko: cc473fe5dc512c450634506f68cbacfb40a06a23
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 45.0a1 (Master)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Repro frequency: 3/3
See attached: video clip and logcat
This issue also occurs on Aries 2.5, Flame 2.6, Flame 2.5, Flame 2.2
Result: Selecting Marketplace app and selecting More option the links do not launch correct pages.

Environmental Variables:
Device: Aries 2.5 kk full flash
Build ID: 20151110170210
Gaia: 07baf613699fa6225359c7f04825c5caeb71d424
Gecko: 361f2673aadc988918a551b45ecef4cce58edf1e
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0a2 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.6 kk full flash
Build ID: 20151110030237
Gaia: c0482775b1526add626b170dd53a72d10bcaf07c
Gecko: cc473fe5dc512c450634506f68cbacfb40a06a23
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 45.0a1 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:45.0) Gecko/45.0 Firefox/45.0

Environmental Variables:
Device: Flame 2.5 kk full flash
Build ID: 20151109004552
Gaia: cf646c52bb947af28329b0a100df91d1b1f2a907
Gecko: 4eafef5b80f8985c94c4a067f130d37513e1a581
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0a2
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Environmental Variables:
Device: Flame 2.2
Build ID: 20151110002502
Gaia: b12374ef1457cab0ae9b330171a373c7160c031a
Gecko: 72a44beba15a
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Repro 1/3
QA Whiteboard: [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
Product: Firefox OS → Marketplace
https://github.com/mozilla/fireplace/pull/1562
Blocks: 1209232
Priority: -- → P1
Target Milestone: --- → 2015-11-24
Assignee: nobody → dspasovski
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
I can't reproduce this issue on a flame with 2.5 and I do not have an Aries to check there. Maybe someone can help here?
NI krupa because I know she has one...
Flags: needinfo?(krupa.mozbugs)
Flags: needinfo?(krupa.mozbugs)
You need to log in before you can comment on or make changes to this bug.