trying to display pdf file opens many, many tabs, shows no content

RESOLVED DUPLICATE of bug 842943

Status

()

RESOLVED DUPLICATE of bug 842943
3 years ago
3 years ago

People

(Reporter: ray, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox45 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8685751 [details]
many_many_tabs.png

I started with a page in one tab:

https://www.amnesty.org/en/documents/mde24/2579/2015/en/

There is a link to get to the PDF report. I selected English for the language and clicked 'Download'.

I get a dialog box to open the document. I want to open the document. I navigate to /usr/bin/firefox and tell it to open it with that. I would like it to open with "Firefox", but where is that? What I have is "/usr/bin/firefox".

It opens a tab and then opens many, many more tabs. It keeps opening new tabs until I hit the close bar and then it confirms, do I want to close all 274 tabs? I do.

So, how do I get it to open the PDF document?

This is a freshly installed copy of Ubuntu 15.04. The version of Firefox installed with it is 42.0.
(Reporter)

Comment 1

3 years ago
Ok, so when one goes into the Applications area of the Preferences, it may seem that "Portable Document Format (PDF)" and "PDF Document" are the same thing, but they are not. Or are they? What is the difference?

And the "Portable Document Format (PDF)" offers you "Preview in Firefox". Which is not what I want to do because I want to view the document, not preview it. Oh. Those are the same thing, even though they are different words. Hm. Ok.

And there is no "Preview with Firefox" option for "PDF Document"?

I managed to set the "PDF Document" to "Use (default)". Hopefully the "Portable Document Format (PDF)" setting will trump the "PDF Document" info. It seems to let me view PDF documents. Or rather, I guess,  preview them....

No matter how this is supposed to work, I think that opening an infinite number of tabs from trying to open a document is not good. We will see.

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 842943
You need to log in before you can comment on or make changes to this bug.