From unsigned web page links to signed package won't have process switch

RESOLVED FIXED

Status

Firefox OS
Infrastructure
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: mlien, Assigned: hchang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
[Reproduce Steps]
1. Enable two preferences "network.http.enable-packaged-apps" and "network.http.signed-packages.enabled"
2. Set "network.http.signed-packages.trusted-root" to "http://people.mozilla.org/~mlien/"
3. Navigate to "http://people.mozilla.org/~mlien/index.html"
4. Execute command: "while true; do adb shell b2g-info; done" to monitor process
5. Choose Tab Privileged and tap UItest_Privileged package link

[Expected Result]
Should have process switch

[Actual Result]
It doesn't have process switch

[Build Information]
Build ID               20151110120047
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.111927
Firmware Date          Tue Nov 10 11:19:35 UTC 2015
Bootloader             s1

[Reproduce Rate]
100%
(Reporter)

Updated

3 years ago
QA Whiteboard: [COM=NSec]
(Reporter)

Comment 1

3 years ago
type URL from unsigned web page to signed package in Browser app -> have process switch
type URL from pinned unsigned web page to signed package         -> no process switch
link to signed package from an unsigned web page                 -> no process switch

Updated

3 years ago
Assignee: nobody → hchang
Depends on: 1178526
(Assignee)

Comment 2

3 years ago
Since we choose the approach which doesn't change the parent side loadContext.originAttributes.signedPkg, we need to avoid using GetChannel*Principal in TabParent::ShouldSwitchProcess.
(Assignee)

Comment 3

3 years ago
Created attachment 8688286 [details] [diff] [review]
0001-Bug-1223678-Use-package-identifier-from-argument-to-.patch
Attachment #8688286 - Flags: review?(kchen)
Attachment #8688286 - Flags: review?(kchen) → review+
(Assignee)

Comment 5

3 years ago
Thanks Kanru :)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
Hi, this failed to apply:

patching file netwerk/test/mochitests/mochitest.ini
Hunk #1 FAILED at 3
1 out of 2 hunks FAILED -- saving rejects to file netwerk/test/mochitests/mochitest.ini.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and refresh 0001-Bug-1223678-Use-package-identifier-from-argument-to-.patch

could you rebase this patch ? Thanks!
Flags: needinfo?(hchang)
Keywords: checkin-needed
(Assignee)

Comment 7

3 years ago
Created attachment 8692369 [details] [diff] [review]
patch (rebased)
Attachment #8688286 - Attachment is obsolete: true
Flags: needinfo?(hchang)
(Assignee)

Updated

3 years ago
Keywords: checkin-needed
this caused a bustage on all platforms and so got backedout for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=3484871&repo=b2g-inbound
Flags: needinfo?(hchang)
(Assignee)

Comment 12

3 years ago
Oops! it seems to conflict to another patch which just landed regarding OriginAttribute refactoring...
Flags: needinfo?(hchang)
(Assignee)

Comment 13

3 years ago
Created attachment 8699299 [details] [diff] [review]
Patch (rebased and fixed compile error)
Attachment #8692369 - Attachment is obsolete: true
(Assignee)

Updated

3 years ago
Keywords: checkin-needed

Comment 16

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/643260622894
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.