[XBLFC] Select multiples with size == options.length should not have scrollbars

VERIFIED FIXED in mozilla1.0

Status

()

VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: caillon, Assigned: hyatt)

Tracking

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Linux 2002012821 -

If you have a select multiple with a size of 5 and 5 options, a scrollbar will
appear.  As soon as you click on the scrollbar, it dissapears and the document
reflows.  Testcase coming up.

0. Enable XBL form controls
1. View the testcase
2. Click on any scrollbar in the selects.

Actual: scrollbars are visible and dissapear on click

Expected: the scrollbars shouldn't even be there to begin with as there is
nothing to scroll.  The scrollbars indicate wrongly there are more options to
scroll through.

Note: a select multiple of size 2 gets this correctly, all other sizes are
incorrect.
-> 1.0, nominating for beta1.
Status: NEW → ASSIGNED
Keywords: nsbeta1
Target Milestone: --- → mozilla1.0

Comment 3

17 years ago
ADT triage team needs info: How common is this on top sites, and what is the
worst case scenario when it happens?
Whiteboard: [need info]
Not sure how common this is, I know it happens in Bugzilla though.

Worst case scenario when this happens is that the user tries to scroll down,
only to find that the scrollbar disappears, causing the listbox to shrink and
other items on the page to shift around.  I'd recommend + on this one.
*** Bug 129790 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Summary: [xbl] Select multiples with size == options.length should not have scrollbars → [XBLFC] Select multiples with size == options.length should not have scrollbars

Comment 6

17 years ago
*** Bug 129071 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

17 years ago
--> me
Assignee: bryner → hyatt
Status: ASSIGNED → NEW
(Assignee)

Comment 8

17 years ago
Created attachment 73658 [details] [diff] [review]
mPageCount should just match desiredRows...
Comment on attachment 73658 [details] [diff] [review]
mPageCount should just match desiredRows...

r=bryner
Attachment #73658 - Flags: review+
Comment on attachment 73658 [details] [diff] [review]
mPageCount should just match desiredRows...

sr=ben@netscape.com
Attachment #73658 - Flags: superreview+
(Assignee)

Comment 11

17 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
I was asked to sr, so I'll pick a nit: don't add spaces on an empty line:

-
+  
   AddBorderAndPadding(aSize);

/be
Bug 130308 filed on us still leaving space for the scrollbar though we do not
paint it.

Comment 14

17 years ago
nsbeta1+ per Nav triage team, in case it gets reopened.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [need info]

Comment 15

17 years ago
verified using the testcase and the bugzilla query page.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.