Closed Bug 1223695 Opened 9 years ago Closed 9 years ago

[Skia] failed assertion "__null != texture" in GrTextureAccess::reset

Categories

(Core :: Graphics: Canvas2D, defect)

defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox45 --- affected

People

(Reporter: jruderman, Assigned: pchang)

References

Details

(Keywords: assertion, testcase, Whiteboard: [gfx-noted])

Attachments

(2 files)

Attached file testcase
gfx/skia/skia/src/gpu/GrTextureAccess.cpp:77: failed assertion "__null != texture"

(tested on Mac)
Attached file stack
Hi Jesse,
   I couldn't reproduce this with your testcase in the latest gecko. Do you change any configuration? In my local, the hardware acceleration of canvas is already on by default.
Flags: needinfo?(jruderman)
I did break at GrTextureAccess.cpp:77 but texture is always valid.
Assignee: nobody → howareyou322
Whiteboard: [gfx-noted]
WFM, maybe fixed by the recent Skia update.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(jruderman)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: