[Browser]The prompt box "NEW! Tracking Protection" can't fit screen width.

RESOLVED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Browser
P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Lela(Leave from Mozilla), Assigned: jedireza)

Tracking

({polish})

unspecified
2.6 S2 - 12/4
ARM
Gonk (Firefox OS)
polish

Firefox Tracking Flags

(b2g-v2.2 disabled, b2g-v2.5 affected, b2g-master verified)

Details

(Whiteboard: [systemsfe])

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
Created attachment 8685888 [details]
Bug picture:Flame_v2.6.png

[1.Description]:
[Flame kk v2.5&2.6][Aries kk v2.5&2.6][Browser]When you use Browser the first time, if you switch device to landscape mode, and back to home screen, then launch " Browser " again, you can find the prompt box "NEW! Tracking Protection" is not normally display, as it can't fit screen width.

Found time:15:10
Attach:Flame_v2.6.3gp&logcat_1510.txt&Flame_v2.6.png

[2.Testing Steps]: 
Precondition:    
1. It is the first time to use " Browser ".
2. Connected to a network.

1. Launch " Browser ".
2. Switch to landscape mode.
3. Tap " Home "key.
4. Launch the " Browser " again.
5. Observe the display of the page.

[3.Expected Result]: 
5.The prompt box "NEW! Tracking Protection"should fit the screen width.

[4.Actual Result]: 
5.The prompt box "NEW! Tracking Protection" can't fit screen width.

[5.Reproduction build]: 
Device: Flame kk v2.6 512mb (master) (affected)
Build ID               20151110150205
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151110.182433
Firmware Date          Tue Nov 10 18:24:47 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

Device:Flame kk v2.5 512mb (affected)
Build ID               20151109004552
Gaia Revision          cf646c52bb947af28329b0a100df91d1b1f2a907
Gaia Date              2015-11-09 02:55:50
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/4eafef5b80f8985c94c4a067f130d37513e1a581
Gecko Version          44.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151109.041411
Firmware Date          Mon Nov  9 04:14:26 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

Device: Aries kk v2.6(master) (affected)
Build ID               20151110120047
Gaia Revision          c0482775b1526add626b170dd53a72d10bcaf07c
Gaia Date              2015-11-10 02:25:52
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc473fe5dc512c450634506f68cbacfb40a06a23
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.111927
Firmware Date          Tue Nov 10 11:19:35 UTC 2015
Bootloader             s1

Device: Aries kk v2.5 (affected)
Build ID               20151110094357
Gaia Revision          07baf613699fa6225359c7f04825c5caeb71d424
Gaia Date              2015-11-09 21:32:50
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/e14287b00a514a15418dfaa89287030c588ad19d
Gecko Version          44.0a2
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151110.090331
Firmware Date          Tue Nov 10 09:03:39 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
It doesn't support the Tracking Protection function on FlameKK v2.2.
(Reporter)

Comment 1

2 years ago
Created attachment 8685889 [details]
Bug video: Flame_v2.6.3gp
(Reporter)

Comment 2

2 years ago
Created attachment 8685890 [details]
Bug log: logcat_1510.txt
(Reporter)

Updated

2 years ago
status-b2g-v2.2: --- → disabled
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Whiteboard: [systemsfe]
Keywords: polish
Priority: -- → P1
(Assignee)

Updated

2 years ago
Assignee: nobody → rakhavan
Target Milestone: --- → 2.6 S1 - 11/20
(Assignee)

Comment 3

2 years ago
I tested with the latest master [1] on both Flame and Aries and I'm unable to reproduce this.

To toggle if the tracking protection dialog is shown when you open the browser:

 - Open WebIDE and debug the system app
 - Open your console and enter:
   ```
   navigator.mozSettings.createLock().set({ 'privacy.trackingprotection.shown': false })
   ```
 - Then restart the phone (or the b2g process)
 - Next time you open the browser you'll see the dialog

[1] e8c15ae4e5324a210000ee0a869a962aa542009f
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Target Milestone: 2.6 S1 - 11/20 → 2.6 S2 - 12/4
See Also: → bug 1228146

Updated

2 years ago
Duplicate of this bug: 1228146

Updated

2 years ago
QA Whiteboard: [COM=Tracking Protection]
(Assignee)

Updated

2 years ago
Flags: needinfo?(hejingmei)
(Reporter)

Comment 5

2 years ago
Hi Reza,
I can repro this bug on Build ID 20151115150212 and latest build of Flame master by the STR in comment 0. The key of this bug is that we tap " Home" key in the landscape mode in step 3, and launch the " Browser " again in the portrait mode in step 4. Hope it helps you.
Reproduce rate: 10/10.

Device: Flame KK Master 512mb (affected)
Build ID               20151115150212
Gaia Revision          e8c15ae4e5324a210000ee0a869a962aa542009f
Gaia Date              2015-11-13 00:10:48
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/7cd2d806bd069c0260ff73f023ac85f892b863bf
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151115.184416
Firmware Date          Sun Nov 15 18:44:31 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0

Device: Flame KK Master 512mb (affected)
Build ID               20151130150225
Gaia Revision          702773bee0b70e479ccebe5e061f571e977bc376
Gaia Date              2015-11-30 02:51:04
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a18630f9ab42ddfde03ba8c7757a42069c48c7ed
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151130.184457
Firmware Date          Mon Nov 30 18:45:12 EST 2015
Firmware Version        V18D V4
Bootloader             L1TC000118D0
Flags: needinfo?(hejingmei)
(Reporter)

Updated

2 years ago
QA Whiteboard: [COM=Tracking Protection] → [MGSEI-Triage+]
(Reporter)

Updated

2 years ago
Flags: needinfo?(rakhavan)

Updated

2 years ago
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][COM=Tracking Protection]
(Assignee)

Comment 6

2 years ago
Ah I see, thanks. I was able to reproduce on both Flame and Aries devices. I'll begin debugging and working towards a solution.
Flags: needinfo?(rakhavan)
Created attachment 8695536 [details] [review]
[gaia] jedireza:tracking-protection-notice-sizing-1223703 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8695536 - Flags: review?(apastor)
(Assignee)

Updated

2 years ago
Blocks: 1220293
Comment on attachment 8695536 [details] [review]
[gaia] jedireza:tracking-protection-notice-sizing-1223703 > mozilla-b2g:master

Looks good! Thanks!
Attachment #8695536 - Flags: review?(apastor) → review+
(Assignee)

Comment 9

2 years ago
On master: https://github.com/mozilla-b2g/gaia/commit/2d6941ff2cbc70c6c8fcf523427ddbbd448a75fb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Hi Lela,

    Could you help to verify this bug?

Thank you very much.
Flags: needinfo?(hejingmei)
(Reporter)

Comment 11

2 years ago
This bug has been verified as pass on latest build of Flame kk master and Aries kk master by the STR in comment 0.
Actual results: The prompt box "NEW! Tracking Protection" fit the screen width.
Reproduce rate:0/10

Device:Aries kk master(pass) 
Build ID               20151206002630
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151205.234548
Firmware Date          Sat Dec  5 23:45:56 UTC 2015
Bootloader             s1

Device:Flame kk master 512mb (pass)
Build ID               20151206150208
Gaia Revision          b930e25e9f2e5ec2106dd31005468575cdf87d50
Gaia Date              2015-12-05 03:41:55
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/cc9c6cd756cb744596ba039dcc5ad3065a7cc3ea
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.184313
Firmware Date          Sun Dec  6 18:43:25 EST 2015
Firmware Version        v18d v4
Bootloader             L1TC000118D0
Flags: needinfo?(hejingmei)
(Reporter)

Updated

2 years ago
status-b2g-master: affected → verified
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1231893
You need to log in before you can comment on or make changes to this bug.