Implement call handling/mozTelephony

RESOLVED WONTFIX

Status

P1
normal
RESOLVED WONTFIX
3 years ago
2 months ago

People

(Reporter: libuntu, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:42.0) Gecko/20100101 Firefox/42.0
Build ID: 20151030084315

Steps to reproduce:

I tested Firefox OS 2.5 Developer Preview on my smartphone Huawei Ascend Y300 With CyanogenMod 11 (Android 4.4.4) and i found several errors


Actual results:

No works telephony or messaging system, in fact not even recognize the phone line
Often both buttons volume up / down as the shutdown stop working
Airplane mode is enabled by default on the top bar and alert notifications about failures but to open the notifications shows nothing at all
The configuration options do not work and by selecting any of them, you return to the main screen again (this also applies to all applications that are shown there)


Expected results:

It work telephony, messaging system, buttons volume up/down and shutdown, display the notifications correctly on top bar and the aplications installed by default

(Here i've written a post on my blog about my little experience (in spanish):

http://libuntu.net/2015/11/11/probando-firefoxos-2-5-developer-preview-en-huawei-ascend-y300/)
(Reporter)

Updated

3 years ago
Severity: normal → major

Updated

3 years ago
Component: General → General
Product: Firefox OS → B2GDroid

Updated

3 years ago
Duplicate of this bug: 1226562

Comment 2

3 years ago
Thanks for the report! There are a few different issues here, some of which we're already addressing, see bug 1217782 (volume settings).

Some APIs aren't supported yet, and some we won't be able to support (Airplane mode for example), in these instances we're going to be removing them from the UI.  We'll disable Airplane mode in Gaia in bug 1204091.

Notifications in FirefoxOS Dev Preview require you to allow FirefoxOS access to notifications in the Android settings.

For reference from https://bugzilla.mozilla.org/show_bug.cgi?id=1202767#c2
>  Requires you to allow apps to view Notifications in Android settings:
>  For Android >= 5.0, enable for "Firefox OS" under Settings -> Sound and notifications -> Notification access.
>  For Android >= 4.3 but < 5.0 enable fore "Firefox OS" in Settings -> Security -> Notifications access.

I'll put this in our wiki.

As we've already got bugs for some of these issues I'm going to adjust the title to "Implement call handling/mozTelephony".  (https://developer.mozilla.org/en-US/docs/Web/API/Navigator/mozTelephony)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Testing Firefox OS 2.5 Developer Preview on Huawei Ascend Y300 → Implement call handling/mozTelephony

Updated

3 years ago
Severity: major → normal
Priority: -- → P1

Updated

3 years ago
Duplicate of this bug: 1202751
(Reporter)

Comment 4

3 years ago
(In reply to sgiles from comment #2)
> Thanks for the report! There are a few different issues here, some of which
> we're already addressing, see bug 1217782 (volume settings).
> 
> Some APIs aren't supported yet, and some we won't be able to support
> (Airplane mode for example), in these instances we're going to be removing
> them from the UI.  We'll disable Airplane mode in Gaia in bug 1204091.
> 
> Notifications in FirefoxOS Dev Preview require you to allow FirefoxOS access
> to notifications in the Android settings.
> 
> For reference from https://bugzilla.mozilla.org/show_bug.cgi?id=1202767#c2
> >  Requires you to allow apps to view Notifications in Android settings:
> >  For Android >= 5.0, enable for "Firefox OS" under Settings -> Sound and notifications -> Notification access.
> >  For Android >= 4.3 but < 5.0 enable fore "Firefox OS" in Settings -> Security -> Notifications access.
> 
> I'll put this in our wiki.
> 
> As we've already got bugs for some of these issues I'm going to adjust the
> title to "Implement call handling/mozTelephony". 
> (https://developer.mozilla.org/en-US/docs/Web/API/Navigator/mozTelephony)

The problem is that the configuration options  don't work

Greetings
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.