Note: There are a few cases of duplicates in user autocompletion which are being worked on.

test_bug388794.html fails string match test due to off by one error in Fennec with C++APZ

RESOLVED FIXED in Firefox 45

Status

()

Core
Panning and Zooming
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rbarker, Assigned: rbarker)

Tracking

Trunk
mozilla45
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox45 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
When C++APZ is enabled in Fennec, events that are generated by nsWindowUtil may result in off by one errors when received by the DOM. This is caused by the fact that the PresShell resolution must be applied to the event coordinates before being dispatched which introduces rounding errors. To work around the failure in test_bug388794.html it is necessary to convert the string compares to regex so that the off by one rounding errors may be accounted for.
(Assignee)

Updated

2 years ago
Assignee: nobody → rbarker
(Assignee)

Updated

2 years ago
Blocks: 1206872
(Assignee)

Comment 1

2 years ago
Created attachment 8686225 [details] [diff] [review]
0001-Bug-1223937-test_bug388794.html-fails-string-match-test-due-to-off-by-one-error-in-Fennec-with-C-APZ-15111112-201e8cf.patch
Can we fix this by adding a meta-viewport tag to the test such that the resolution is always 1.0?
Blocks: 1207748
No longer blocks: 1206872
Comment on attachment 8686225 [details] [diff] [review]
0001-Bug-1223937-test_bug388794.html-fails-string-match-test-due-to-off-by-one-error-in-Fennec-with-C-APZ-15111112-201e8cf.patch

roc, we'd like to land this to fix this test on Fennec with the C++ APZ. There's rounding errors caused by the resolution. The other alternative is to just disable the test on Fennec.
Attachment #8686225 - Flags: review?(roc)
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #2)
> Can we fix this by adding a meta-viewport tag to the test such that the
> resolution is always 1.0?

(For the record, the problem with this is that the test runs inside an iframe in the harness, and so meta-viewport tags don't make a difference. At least that's what we think.. haven't tried it)
Attachment #8686225 - Flags: review?(roc) → review+

Comment 5

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1946937e23af
https://hg.mozilla.org/mozilla-central/rev/1946937e23af
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.