reset l10n beta/release mercurial repository for 'lo'

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Pike, Assigned: hwine)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1213067 +++

Please reset releases/l10n/mozilla-beta, and -release hg repositories.

We had a snafu there, and getting them to be empty would be the best step forward.

Please keep the aurora repo as is.
(Assignee)

Comment 1

2 years ago
(In reply to Axel Hecht [:Pike] from comment #0)
> Please reset releases/l10n/mozilla-beta, and -release hg repositories.

Per irc chat in #vcs, this is for locale 'lo' only.

Safe to reset repos, as 'lo' has not yet been built (see bug 1208607)
Assignee: nobody → hwine
Blocks: 1208607
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
Done, and confirmed.

Process, since we don't have this scripted:

On hgssh1, reset repos:
    - as user 'hg':
        $ cd /repo/hg/mozilla/releases/l10n/mozilla-beta/lo/
        $ cp -ip .hg/hgrc ..
    - as user 'root':
        $ cd /repo/hg/mozilla/releases/l10n/mozilla-beta/lo/
        $ rm -rf .hg
    - as user 'hg':
        $ hg init
        $ chmod -R g+w,o+rX .hg
        $ mv -i ../hgrc .hg/
repeated for /repo/hg/mozilla/releases/l10n/mozilla-beta/lo/

On webheads, remove mirror:
    $ csshX hgweb{1..10}
    $ sudo su -
    $ cd /repo/hg/mozilla/releases/l10n/mozilla-beta/
    $ rm -rf lo
    $ cd ../mozilla-release/
    $ rm -rf lo

On hgssh2, re-establish mirrors:
    - as user 'root':
        $ cd /repo/hg/mozilla/releases/l10n/mozilla-beta/lo/
        $ /repo/hg/scripts/push-repo.sh
        $ cd ../../mozilla-release/lo/
        $ /repo/hg/scripts/push-repo.sh

In IRC, asked releng to reset the schedulers just in case something was polling these repos. Done by coop.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.