CSS properties on 'body' has no affect in HTML mail

VERIFIED WORKSFORME

Status

MailNews Core
Backend
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: Jonas Jørgensen, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Send yourself a text/html email containing the following lines:

<html>
<head>
<style type='text/css'>
body {font-family: Arial, sans-serif; font-size: 0.81em;}
</style>
</head>
<body>
<p>Some text</p>
</body>
</html>

The words "Some text" will be shown in your default font, not as 0.81em Arial.
If the line

body {font-family: Arial, sans-serif; font-size: 0.81em;}

was changed to

p {font-family: Arial, sans-serif; font-size: 0.81em;}

, or if the text was inside a table, and the line was changed to

td {font-family: Arial, sans-serif; font-size: 0.81em;}

, "Some text" would be 0.81em Arial. This leads to different fonts being used
for pieces of text that was intended to be shown in the same font, and that is
annoying.
(Reporter)

Comment 1

16 years ago
I can no longer reproduce this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 2

16 years ago
verified per reporters comments 
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.