Window freezes when resizing during typing in URL bar

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: whavinga, Assigned: attinasi)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Short description is in summary.

Steps to reproduce:

1. Open a new Mozilla window
2. Go to the URL bar
3. Hold your mouse pointer somewhere where you can resize the window
4. Type something in the URL bar, while resizing the window with your mouse. 

NOTE: Step (4) may not be possible on all platforms, on Win2K I could not do
this, but on Win98 and Linux (KDE 2.2.2) I could. Therefore I marked this bug
'all platforms' as there seems to be a single race condition causing the
problems on several platforms where you *can* actually do it.
In Win2K it is plain impossible to resize the window while typing in the URL
bar, the event just doesn't get through or something! On Linux, it might even be
Window Manager specific as far as I can tell.

What happens:

1. The window freezes, i.e. I see the content as it was before the resize, but
it doesn't render the page in it's new size, leaving gray areas where you
resized the window (if you made it bigger).
2. In Linux only solution is to close the window, while in Windows it apparently
redraws after I resize it again (without typing).


Looks like there is some race condition between these events or something, this
might be a nasty one to find (but I'm not a Mozilla programmer :)

Resizing while typing in a text box or any other area of the screen I tried
seems to work just fine, so the problem is pretty specific just for the URL bar.

I tried this in Mozilla 0.9.7, both the Linux and Windows build, and in the
latest (28/01/2002) 0.9.8 Windows build it still 'worked'.

Hope that's enough info for this bug report to be usefull!

Comment 1

17 years ago
worksforme on 021115 mozilla linux build (redhat 7.2) For me the content does a
reflow every half second or something like that so it fills in as I drag the
window larger.
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen

Comment 2

17 years ago
I'm getting the same result as Asa in the Feb 25th OS X build. Marking WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.