Mention new "Hide Menu Bar" feature in Help

VERIFIED FIXED in seamonkey2.47

Status

VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: RainerBielefeldNG, Assigned: isaacschemm)

Tracking

(Blocks: 2 bugs)

SeaMonkey 2.39 Branch
seamonkey2.47
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.40 affected)

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

3 years ago
Users should know that there is a new MS feature.

Details concerning the feature: Bug 1153577 User Story
(Reporter)

Updated

3 years ago
See Also: → bug 1153577
(Reporter)

Comment 1

3 years ago
NEW due to <https://blog.seamonkey-project.org/2015/11/25/my-unconfirmed-bug-reports/>
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Summary: Mention "Hide Menu Bar" feature in Help → Mention new "Hide Menu Bar" feature in Help
(Assignee)

Comment 2

3 years ago
Created attachment 8699112 [details] [diff] [review]
smMenuBarHelpInfo

Here's a patch to add information about the Menu Bar (including a screenshot, and information on showing it with Alt) to the "Customizing SeaMonkey" > "Toolbars" section of SeaMonkey Help. This is my first patch uploaded to bugzilla - hopefully I did it properly :)

Feel free to suggest different language on the help page too.

Comment 3

3 years ago
Comment on attachment 8699112 [details] [diff] [review]
smMenuBarHelpInfo

Thanks for the patch!

Setting the review flag. Otherwise nobody will know about this patch!
Attachment #8699112 - Flags: review?(iann_bugzilla)
Attachment #8699112 - Flags: feedback?(rsx11m.pub)
(Reporter)

Comment 4

3 years ago
May be we should wait with a fix here until 
a) "Bug 1224907 - Bookmarks Manager Search missing in Mac Menu Bar" has become fixed
b) we know whether there really is a Linux problem due to Bug 1153577 Comment#15

Comment 5

3 years ago
Note that on mac there's no menubar attached to an application's window. Instead, an application have a single menubar that sits on top of the screen (the "Hide Menu Bar" feature is a win/nix feature).

Comment 6

3 years ago
For content that only should be visible on certain platforms we have http://mxr.mozilla.org/mozilla-central/source/toolkit/components/help/content/platformClasses.css. In this case 'class="noMac"' can be used to hide content for Mac users.

Comment 7

3 years ago
Comment on attachment 8699112 [details] [diff] [review]
smMenuBarHelpInfo

Looks good overall, a couple of issues though:

>+  <tr> 
>+    <td><img src="images/menubar.png" alt="Menu Bar"/></td>
>+  </tr>

You need to add a line to suite/locales/jar.mn for the image file to be included in the packing manifest:
>+  locale/@AB_CD@/communicator/help/images/menubar.png (%chrome/common/help/images/menubar.png)

>+<p>If the Menu Bar is hidden (see <a href="#hiding_a_toolbar">Hiding a Toolbar</a>),
>+  or if you are in Full Screen mode, press the Alt key to display the Menu Bar.</p>

There was an issue with Linux where the menu bar doesn't show up with ALT alone but only when the first key to navigate is pressed (I'll have to check if that's still the case; if yes, more details need to be provided to regain control for the menu bar).

It probably also should be mentioned that the ALT key won't have any effect if the menu bar is hidden by the triangle (unless I'm doing this wrong).

> <ol>
>-  <li>Open the View menu.</li>
>+  <li>Open the View menu and choose Show/Hide.</li>
>   <li>Choose Show/Hide and uncheck the toolbars you want to hide.</li>
> </ol>

This change appears to be redundant? If you want to keep the change in that list item for consistency, remove the first part of the second list item, thus starting with "Uncheck" directly.
Attachment #8699112 - Flags: feedback?(rsx11m.pub) → feedback-

Updated

3 years ago
Assignee: nobody → isaacschemm
Status: NEW → ASSIGNED

Comment 8

3 years ago
Comment on attachment 8699112 [details] [diff] [review]
smMenuBarHelpInfo

Good first patch, thanks.

As well as rsx11m's suggestions, you will need to add entries to:
/suite/locales/en-US/chrome/common/help/help-index1.rdf
/suite/locales/en-US/chrome/common/help/suite-toc.rdf
and possibly the glossary too.

Compare with navigation_toolbar or component_bar:
http://mxr.mozilla.org/comm-central/search?string=navigation_toolbar
http://mxr.mozilla.org/comm-central/search?string=component_bar
Attachment #8699112 - Flags: review?(iann_bugzilla) → review-

Comment 9

3 years ago
See also comment #6.
(Assignee)

Comment 10

3 years ago
Created attachment 8707114 [details] [diff] [review]
smMenuBarHelpInfo2.patch

I uploaded a new patch. Let me know if I should be putting someone different under the review and/or feedback flags.
Attachment #8699112 - Attachment is obsolete: true
Attachment #8707114 - Flags: review?(iann_bugzilla)
Attachment #8707114 - Flags: feedback?(rsx11m.pub)

Comment 11

3 years ago
Comment on attachment 8707114 [details] [diff] [review]
smMenuBarHelpInfo2.patch

>+++ b/suite/locales/en-US/chrome/common/help/customize_help.xhtml

>+<p>The Menu Bar provides drop down menus for performing actions within SeaMonkey.</p>
Sorry, I should have picked this up first time round. Instead of SeaMonkey you should use &brandShortName;
Also is this line within the 80 line limit? Need to make sure other changes are too.


>+++ b/suite/locales/en-US/chrome/common/help/glossary.xhtml

>+<dt id="menu_bar">Menu Bar</dt><dd>The toolbar <span class="mac">at the top
>+  of the screen</span><span class="noMac">near the top of the browser window</span>
>+  that includes the File, Edit and View menus.</dd>
Rather than "the browser window" it should be "any &brandShortName; window"

Getting there so f+
I would like to review the next patch but might be worth waiting for feedback from rsx11m before generating that.
Attachment #8707114 - Flags: review?(iann_bugzilla) → feedback+

Comment 12

3 years ago
Comment on attachment 8707114 [details] [diff] [review]
smMenuBarHelpInfo2.patch

Looks good. I didn't apply the patch but the RDF wiring should work.

>+<p class="noMac">If the Menu Bar is hidden (not minimized; see
>+  <a href="#hiding_a_toolbar">Hiding a Toolbar</a>), or if you are in Full
>+  Screen mode, press the Alt key to display the Menu Bar.</p>

That's better with the "not minimized" added. It also reminds me that I wanted to double-check that the ALT key works the same way on Linux by now... I'll get back to you on that.

>+<dt id="menu_bar">Menu Bar</dt><dd>The toolbar <span class="mac">at the top
>+  of the screen</span><span class="noMac">near the top of the browser window</span>
>+  that includes the File, Edit and View menus.</dd>

I think in en-US it's "File, Edit, and View menus."
Attachment #8707114 - Flags: feedback?(rsx11m.pub) → feedback+
(Assignee)

Comment 13

3 years ago
For me (on an openSUSE 42.1 virtual machine), the menu bar doesn't appear if you just hit Alt, but it shows up if you do (for example) Alt+F for the File menu. This might just be a bug, though, so I'm not sure what the help should say about it.

I'll upload another patch with the other changes mentioned.
(Assignee)

Comment 14

3 years ago
Created attachment 8709140 [details] [diff] [review]
Third patch for describing new menu bar functionality in Help
Attachment #8707114 - Attachment is obsolete: true
Attachment #8709140 - Flags: review?(iann_bugzilla)
Attachment #8709140 - Flags: feedback?(rsx11m.pub)

Comment 15

3 years ago
Comment on attachment 8709140 [details] [diff] [review]
Third patch for describing new menu bar functionality in Help

(In reply to isaacschemm from comment #13)
> For me (on an openSUSE 42.1 virtual machine), the menu bar doesn't appear if you
> just hit Alt, but it shows up if you do (for example) Alt+F for the File menu.

I see the same thing on my Linux installation with KDE4. But then, looking at http://mxr.mozilla.org/comm-central/source/suite/locales/en-US/chrome/common/help/shortcuts.xhtml#222 shows that the intended (implemented) shortcut to temporarily show the menu bar on Linux is actually F10 rather than the ALT key. That works for me, though slightly different than on Windows as it also opens the menu of the first item (usually "File").
  
>+<p class="noMac">If the Menu Bar is hidden (not minimized; see
>+  <a href="#hiding_a_toolbar">Hiding a Toolbar</a>), or if you are in Full
>+  Screen mode, press the Alt key to display the Menu Bar.</p>

So, either another platform-restricted paragraph is needed for Linux, or you just add a sentence that F10 is the equivalent of ALT if it doesn't work (and it does the same thing on Windows, I can't test Mac OSX though).
Attachment #8709140 - Flags: feedback?(rsx11m.pub) → feedback+
(Assignee)

Comment 16

3 years ago
Since F10 also works on Windows, should we mention that instead of Alt?

The menu bar is an OS feature on OS X, so I don't think this feature applies - you can't hide the menu bar from SeaMonkey since it's not part of the application window.
(Reporter)

Comment 17

3 years ago
(In reply to isaacschemm from comment #16)
> Since F10 also works on Windows, should we mention that instead of Alt?

At least for WIN and probably Linux I would prefer to get the <alt> solution working. <alt> is very common to activate the top left item of the menu bar, and probably many users would prefer continuity. May be accessibility for users who need to use keyboard for navigation (may be even speech control?) would prefer <alt>? What works for visible menu bar also should work for the hidden one.
(Assignee)

Comment 18

3 years ago
Should we just wait on this until we can get Alt working then? That would be OK with me.

Updated

3 years ago
Attachment #8709140 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 8709140 [details] [diff] [review]
Third patch for describing new menu bar functionality in Help

I was going to check this in, but I noticed one thing:

+<p>To reverse this action, open the View menu, choose Show/Hide, and then
+  select the toolbars you want to show. You can also right-click on an empty
+  section on the Menu Bar, Navigation Toolbar, or Bookmarks Toolbar to turn
+  toolbars on and off.</p>

This is actually not correct if you're on Mac: you can't right-click on the menubar and bring up a context menu. If you put the "Menu Bar" at the end, you could wrap that in a noMac <span>

The screenshot isn't really mac-like and I don't really think a menubar is a toolbar in the mac world, but I guess we can live with that (and Ian have obviously decided it's OK) :-)

Updated

3 years ago
Flags: needinfo?(isaacschemm)

Updated

3 years ago
Blocks: 1268037
(Assignee)

Comment 20

3 years ago
Created attachment 8762755 [details] [diff] [review]
smMenuBarHelpInfo4.patch

Good catch. Here's an updated patch.
Attachment #8709140 - Attachment is obsolete: true
Flags: needinfo?(isaacschemm)
Attachment #8762755 - Flags: review?(stefanh)
Comment on attachment 8762755 [details] [diff] [review]
smMenuBarHelpInfo4.patch

Thanks.
Attachment #8762755 - Flags: review?(stefanh) → review+
https://hg.mozilla.org/comm-central/rev/cc9ec56a0499

Btw, you want the commit message to always start with the bug number (Bug 123456 - your description). People usually add the reviewer as well (usually like "r?reviewer".
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.47
(Reporter)

Comment 23

3 years ago
VERIFIED with  English SeaMonkey 2.47a1  (NT 6.1; Win64; x64; rv:50.0)  Gecko/20100101 Firefox/50.0 Build 20160628114904  (Default Classic Theme)  on German WIN7 64bit: A new paragraph "Menu Bar" has been created.
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

3 years ago
Blocks: 1276703

Updated

2 years ago
Depends on: 1287179
You need to log in before you can comment on or make changes to this bug.