No zoom cursor on scaled images in GNOME 3.18

RESOLVED DUPLICATE of bug 1233868

Status

()

RESOLVED DUPLICATE of bug 1233868
3 years ago
2 years ago

People

(Reporter: lucas.werkmeister, Unassigned)

Tracking

44 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Open an image large enough to not fit within your browser viewport, i. e. the browser scales it. For most screen sizes, this plain white 2000×2500px image probably works: https://i.imgur.com/pY1GVd1.jpg . Alternatively, resize your browser window or use Responsive Design View.
2. Move your mouse cursor over the image.
3. Click the image.

Expected results:
- Step 2: cursor changes to “zoom in” cursor.
- Step 3: cursor changes to “zoom out” cursor.

Actual results:
- Steps 2 and 3: cursor remains regular “mouse” cursor.

System: Arch Linux, with GNOME desktop environment. I have been experiencing this since I upgraded from GNOME 3.16 to 3.18. The GNOME “Web” browser (aka Epiphany) displays “zoom in” and “zoom out” cursors for the same steps, so I don’t think this is an intentional change in GNOME.
(Reporter)

Updated

3 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

3 years ago
Yeah they would not show up on this test page too: https://developer.mozilla.org/en-US/docs/Web/CSS/cursor

I tried adwaita-icon-themes (which provides the cursors) 3.16.2 and it doesn't work in firefox either, so I wonder if it just starts from a firefox 41 (which was pushed on the same day as gnome/gtk 3.18 in arch).

Comment 2

3 years ago
Hmm never mind. Just tested with Arch Linux Archive and found that 43.0-1 was the first version having the bug introduced.

Not sure if it's relevant but it's the same release that Arch switch to (cairo-)gtk3: https://projects.archlinux.org/svntogit/packages.git/commit/trunk?h=packages/firefox&id=508d2576cbd5699f8343e5e3540d540219992df6

Comment 3

3 years ago
I got the same thing after I did a full system update, I got Arch Linux with XFCE Desktop.

The cursor changes fine in chrome, so it's not a problem in the website itself

Comment 4

3 years ago
Probably a duplicate of bug 1233868
(Reporter)

Comment 5

3 years ago
I just noticed that this is now working for me as of Firefox45.0a2 aurora, Build ID 20151220004007, Built from https://hg.mozilla.org/releases/mozilla-aurora/rev/1ba4f6d91e637348dc0cdc7e9d311c4cddbc8a5e.

Comment 6

3 years ago
The latest Arch update fixed the issue for me
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233868
You need to log in before you can comment on or make changes to this bug.